A - Apple Tree dfs&树状数组|线段树

知识共享许可协议
本作品采用知识共享署名-相同方式共享 4.0 国际许可协议进行许可。
题目描述:
There is an apple tree outside of kaka’s house. Every autumn, a lot of apples will grow in the tree. Kaka likes apple very much, so he has been carefully nurturing the big apple tree.
The tree has N forks which are connected by branches. Kaka numbers the forks by 1 to N and the root is always numbered by 1. Apples will grow on the forks and two apple won’t grow on the same fork. kaka wants to know how many apples are there in a sub-tree, for his study of the produce ability of the apple tree.
The trouble is that a new apple may grow on an empty fork some time and kaka may pick an apple from the tree for his dessert. Can you help kaka?

Input
The first line contains an integer N (N ≤ 100,000) , which is the number of the forks in the tree.
The following N - 1 lines each contain two integers u and v, which means fork u and fork v are connected by a branch.
The next line contains an integer M (M ≤ 100,000).
The following M lines each contain a message which is either
“C x” which means the existence of the apple on fork x has been changed. i.e. if there is an apple on the fork, then Kaka pick it; otherwise a new apple has grown on the empty fork.
or
“Q x” which means an inquiry for the number of apples in the sub-tree above the fork x, including the apple (if exists) on the fork x
Note the tree is full of apples at the beginning
Output
For every inquiry, output the correspond answer per line.
Sample Input
3
1 2
1 3
3
Q 1
C 2
Q 1

Sample Output
3
2

参考博客:https://blog.csdn.net/libin56842/article/details/46634095#commentBox
https://blog.csdn.net/cax1165/article/details/52192412
分析:
前两天还大言不惭的说,不会卡vector的。结果这个题还真就卡了,还是老老实实的去看下前向星吧。
总之则个题我吧vector Q[100100] 改成vector<vector > Q(100100); 就ac了。

这个题目,我是真想不到竟然是先用dfs求出序列。在用树状数组来维护。
用一个dfs把这个树结点的编号,及其最大的子孩子编号记录下来。那么以这个结点为根的子树里面的sum就是ask[out[x]] - ask[in[x]-1]。
具体看代码吧

#include"stdio.h"
#include"string.h"
#include"vector"
#include"algorithm"
using namespace std;

int N,M,top;
vector<vector<int> > Q(100100);
int in[100100],out[100100];
int sum[100100];int C[100100];
int val[100100];

int lowbit(int x)
{
    return x & (-x);
}

int ask(int x)
{
    int ans = 0;
    while(x >= 1)
    {
        ans += C[x]; x -= lowbit(x);
    }
    return ans;
}
void add(int x,int v)
{
    while(x <= top)
    {
        C[x] += v; x += lowbit(x);
    }
}

void dfs(int x)
{
    in[x] = ++ top;//保存这个结点的编号
    for(int i = 0; i < Q[x].size(); i ++)
    {
        int v = Q[x][i];
        dfs(v);
    }
    out[x] = top; //保存这个结点的最大子孩子的编号
}

int main()
{
    scanf("%d",&N);
    for(int i = 1; i < N; i ++)
    {
        int x,y;
        scanf("%d%d",&x,&y);
        Q[x].push_back(y);
    }
    dfs(1);
    scanf("%d",&M);
    for(int i = 1; i <= top; i ++)
        {
            add(i,1); val[i] = 1;
        }
    for(int i = 1; i <= M; i ++)
    {
        char str[10];
        int x;
        scanf("%s%d",str,&x);
       // printf("x = %d\n",x);
        if(str[0] == 'Q')
        {
            printf("%d\n",ask(out[x]) - ask(in[x] - 1)); continue;
        }
        int v = in[x];
        val[x] ^= 1;
        if(val[x] == 0)
            add(v,-1);
        else
            add(v,1);
    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值