E - 牛逼闪闪的爷爷

The whole family was excited by the news. Everyone knew grandpa had been an extremely good bridge player for decades, but when it was announced he would be in the Guinness Book of World Records as the most successful bridge player ever, whow, that was astonishing!
The International Bridge Association (IBA) has maintained, for several years, a weekly ranking of the best players in the world. Considering that each appearance in a weekly ranking constitutes a point for the player, grandpa was nominated the best player ever because he got the highest number of points.
Having many friends who were also competing against him, grandpa is extremely curious to know which player(s) took the second place. Since the IBA rankings are now available in the internet he turned to you for help. He needs a program which, when given a list of weekly rankings, finds out which player(s) got the second place according to the number of points.
Input
The input contains several test cases. Players are identified by integers from 1 to 10000. The first line of a test case contains two integers N and M indicating respectively the number of rankings available (2 <= N <= 500) and the number of players in each ranking (2 <= M <= 500). Each of the next N lines contains the description of one weekly ranking. Each description is composed by a sequence of M integers, separated by a blank space, identifying the players who figured in that weekly ranking. You can assume that:
in each test case there is exactly one best player and at least one second best player,
each weekly ranking consists of M distinct player identifiers.

The end of input is indicated by N = M = 0.
Output
For each test case in the input your program must produce one line of output, containing the identification number of the player who is second best in number of appearances in the rankings. If there is a tie for second best, print the identification numbers of all second best players in increasing order. Each identification number produced must be followed by a blank space.
Sample Input
4 5
20 33 25 32 99
32 86 99 25 10
20 99 10 33 86
19 33 74 99 32
3 6
2 34 67 36 79 93
100 38 21 76 91 85
32 23 85 31 88 1
0 0
Sample Output
32 33
1 2 21 23 31 32 34 36 38 67 76 79 88 91 93 100

题意:给你每周的分数,让你输出出现次数为第二大的全部分数;

解题思路:我一开始直接,记录次数,找第二大的次数记录,用到去重,然后直接可以用冒泡排序,从大到小排序后去重,后输出出现第二大次数的分数就可以了;这个代码有点长,当然,你也可以用字典序去做,这样会很快,代码也短;

后再填坑,现在继续做题了;

#include <iostream>
#include<cstdio>
#include<algorithm>
#include<string.h>
using namespace std;
int n,m;
int b[10005];
int a[10005][10005];
int c[10005];
int main()
{
    while(cin>>n>>m)
    {
        if(n==0&&m==0)
            break;
        int y=0;
        for(int i=0; i<n; i++)//清零
        {
            for(int j=0; j<m; j++)
            {
                a[i][j]=0;
            }
        }
        memset(b,0,sizeof(b));
        //memset(c,0,sizeof(c));
        for(int i=0; i<n; i++)
        {
            for(int j=0; j<m; j++)
            {
                cin>>a[i][j];
                b[a[i][j]]+=1;//标记,记录次数
                //c[y++]=a[i][j];//存数
            }
        }
        int maxx=0;
        int ma;
        for(int i=0; i<n; i++)//找出出现最大次数的分数
        {
            for(int j=0; j<m; j++)
            {
                if(maxx<=b[a[i][j]])
                {
                    maxx=b[a[i][j]];
                    ma=a[i][j];
                }
            }
        }
        int minn=0;
        for(int i=0; i<n; i++)
        {
            for(int j=0; j<m; j++)//找出出现第二大出现次数的分数
            {
                if(maxx!=b[a[i][j]])
                {
                    if(minn<=b[a[i][j]])
                        minn=b[a[i][j]];
                }
            }
        }
        int w=0;
        int yy[150000];
        memset(yy,0,sizeof(yy));
        for(int i=0; i<n; i++)//记录
        {
            for(int j=0; j<m; j++)
            {
                if(b[a[i][j]]==minn)//记录全部出现第二次大的分数
                {
                    yy[w++]=a[i][j];
                }
            }
        }
        for(int i=0;i<w-1;i++)//冒泡排序
        {
            for(int j=0;j<w-1-i;j++)
            {
                if(yy[j]>yy[j+1])
                {
                    int tt=yy[j];
                    yy[j]=yy[j+1];
                    yy[j+1]=tt;
                }
            }
        }
        int bb[10005];
        int index=1;
        bb[0]=yy[0];
        for(int i=1;i<w;i++)//去重
        {
            if(yy[i]!=yy[i-1])
            {
                bb[index++]=yy[i];
            }
        }
        sort(bb,bb+index);//从小到大排序
        for(int i=0; i<index; i++)//输出
        {
            if(bb[i]==ma)//去掉出现次数为第一大的数
                continue;
            if(i!=index-1)
                cout<<bb[i]<<" ";
            else
                cout<<bb[i]<<endl;
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值