X

Description

The whole family was excited by the news. Everyone knew grandpa had been an extremely good bridge player for decades, but when it was announced he would be in the Guinness Book of World Records as the most successful bridge player ever, whow, that was astonishing! 
The International Bridge Association (IBA) has maintained, for several years, a weekly ranking of the best players in the world. Considering that each appearance in a weekly ranking constitutes a point for the player, grandpa was nominated the best player ever because he got the highest number of points. 
Having many friends who were also competing against him, grandpa is extremely curious to know which player(s) took the second place. Since the IBA rankings are now available in the internet he turned to you for help. He needs a program which, when given a list of weekly rankings, finds out which player(s) got the second place according to the number of points.

Input

The input contains several test cases. Players are identified by integers from 1 to 10000. The first line of a test case contains two integers N and M indicating respectively the number of rankings available (2 <= N <= 500) and the number of players in each ranking (2 <= M <= 500). Each of the next N lines contains the description of one weekly ranking. Each description is composed by a sequence of M integers, separated by a blank space, identifying the players who figured in that weekly ranking. You can assume that: 
  • in each test case there is exactly one best player and at least one second best player, 
  • each weekly ranking consists of M distinct player identifiers.

The end of input is indicated by N = M = 0.

Output

For each test case in the input your program must produce one line of output, containing the identification number of the player who is second best in number of appearances in the rankings. If there is a tie for second best, print the identification numbers of all second best players in increasing order. Each identification number produced must be followed by a blank space.

Sample Input

4 5
20 33 25 32 99
32 86 99 25 10
20 99 10 33 86
19 33 74 99 32
3 6
2 34 67 36 79 93
100 38 21 76 91 85
32 23 85 31 88 1
0 0

Sample Output

32 33
1 2 21 23 31 32 34 36 38 67 76 79 88 91 93 100

题目分析

爷爷因为得分最高而被提名为最好的球员。 有很多朋友也在和他竞争,爷爷非常好奇地知道哪个玩家是第二名。由于IBA的排名现已在互联网上提供,所以他转而向你寻求帮助。他需要一个程序。

输入N*M,N就是N次比赛,M是个人成绩,也是个人身份。
N次比赛中出现次数最多的就是爷爷,要输出出现次数仅此于爷爷的所有人

解题思路

是输出数字出现次数第二多的数字,并且按顺序输出。即先获取最大的值然后据此找到第二大的值。

源代码

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
struct play
{
    int num;
    int s;
};
bool cmp(play a,play b)
{
    if(a.s==b.s)
        return a.num<b.num;
    else
        return a.s>b.s;
}
int main()
{
    int n,m,i,j;
    while(scanf("%d%d",&n,&m))
    {
        play p[10003];
        memset(p,0,sizeof(p));
        int temp;
        if(n==0 && m==0)
            break;
        for(i=0;i<n;i++)
            for(j=0;j<m;j++)
            {
                scanf("%d",&temp);
                p[temp].num=temp;
                p[temp].s++;
            }
        sort(p,p+10000,cmp);
        i=1;
        while(p[i].s==p[i+1].s)
        {
            printf("%d ",p[i].num);
            i++;
        }
        printf("%d\n",p[i].num);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值