Advanced Fruits 规定顺序版!

The company “21st Century Fruits” has specialized in creating new sorts of fruits by transferring genes from one fruit into the genome of another one. Most times this method doesn’t work, but sometimes, in very rare cases, a new fruit emerges that tastes like a mixture between both of them.
Picture of the Mixture of Apple and Pear

A big topic of discussion inside the company is “How should the new creations be called?” A mixture between an apple and a pear could be called an apple-pear, of course, but this doesn’t sound very interesting. The boss finally decides to use the shortest string that contains both names of the original fruits as sub-strings as the new name. For instance, “applear” contains “apple” and “pear” (APPLEar and apPlEAR), and there is no shorter string that has the same property.

A combination of a cranberry and a boysenberry would therefore be called a “boysecranberry” or a “craboysenberry”, for example.

Your job is to write a program that computes such a shortest name for a combination of two given fruits. Your algorithm should be efficient, otherwise it is unlikely that it will execute in the allowed time for long fruit names.

Input
There are multiple test cases, The first line of the input contains an integer T(about 100), indicating the number of test cases. For each test case:

Each test case contains two strings that represent the names of the fruits that should be combined. All names have a maximum length of 100 and only consist of alphabetic characters.

Output
For each test case, output the shortest name of the resulting fruit on one line. If more than one shortest name is possible, you should print the answer with the leftmost position of the first given string.

Sample Input
3
apple peach
ananas banana
pear peach
Sample Output
appleach
bananas
pearch
Hint
For the third test case, there exists multiple answers, such as “pearch”, “peachr”, “peacrh”, and you should output “pearch”, because the first given word “pear” is at the leftmost position of word “pearch”.

#include<iostream>
#include<algorithm>
#include<cstring>
#include<math.h>
#include<cmath>
#include<set>
#include<map>
#include<stack>
#include<queue>
#include<vector>
#include <string>
#define EPS 1e-6
#define zero 1e-3
#define INF 0x3f3f3f3f
using namespace std;
int dp[110][110];
int mark[110][110];
string s1,s2;
void print(int x,int y)
{
	if(x==0&&y==0)
		return;
	if(mark[x][y]==1)
	{
		print(x-1,y-1);
		cout<<s1[x-1];
	}
	else if(mark[x][y]==2)
	{
		print(x-1,y);
		cout<<s1[x-1];
	}
	else if(mark[x][y]==3)
	{
		print(x,y-1);
		cout<<s2[y-1];
	}
}
int main()
{
	int n;
	cin>>n;
	while(n--)
	{
		memset(dp,0,sizeof(dp));
		cin>>s1>>s2;
		int len1=s1.size();
		int len2=s2.size();
		for(int i=0;i<=len1;i++)
			mark[i][0]=2;
		for(int i=0;i<=len2;i++)
			mark[0][i]=3;
		for(int i=1;i<=len1;i++)
		{
			for(int j=1;j<=len2;j++)
			{
				if(s1[i-1]==s2[j-1])
				{
					dp[i][j]=dp[i-1][j-1]+1;
					mark[i][j]=1;
				}
				else
				{
					if(dp[i-1][j]>dp[i][j-1])//这里不要等于很关键,不然输出顺序不同.
					{
						dp[i][j]=dp[i-1][j];
						mark[i][j]=2;
					}
					else
					{
						dp[i][j]=dp[i][j-1];
						mark[i][j]=3;
					}
				}
			}
		}
		print(len1,len2);
		cout<<endl;
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值