HDOJ 2056 相交矩形的面积

Problem Description Given two rectangles and the coordinates of two points on the diagonals of each rectangle,you have to calculate the area of the intersected part of two rectangles. its sides are parallel to OX and OY .
Input Input The first line of input is 8 positive numbers which indicate the coordinates of four points that must be on each diagonal.The 8 numbers are x1,y1,x2,y2,x3,y3,x4,y4.That means the two points on the first rectangle are(x1,y1),(x2,y2);the other two points on the second rectangle are (x3,y3),(x4,y4).

Output Output For each case output the area of their intersected part in a single line.accurate up to 2 decimal places.
Sample Input
1.00 1.00 3.00 3.00 2.00 2.00 4.00 4.00
5.00 5.00 13.00 13.00 4.00 4.00 12.50 12.50
Sample Output
1.00
56.25

首先要用快速排斥确定两个矩形是否相交
在这里插入图片描述
P1坐标为(p1x,p1y),P2坐标为(p2x,p2y),Q1的坐标为(q1x,q1y),Q2的坐标为(q2x,q2y)。
那矩形相交的条件就是:
min(p1x,p2x) <= max(q1x,q2x) &&
min(q1x,q2x) <= max(p1x,p2x) &&
min(p1y,p2y) <= max(q1y,q2y) &&
min(q1y,q2y) <= max(p1y,p2y)
注意这里不能用sort函数排序,因为sort只能排序整个数组,不能部分排序。

排除不相交的情况,然后将四个xy坐标分别排序(记为x1,x2…y1,y2…),s=(x3-x2)*(y3-y2)

#include <iostream>
#include<cstdio>
#include <iomanip>
#include<cmath>
using namespace std;
double max(double a, double b)
{
    if (a > b)
        return a;
    else
        return b;
}
double min(double a, double b)
{
    if (a < b)
        return a;
    else
        return b;
}
int main()
{
   int i,n;
   double x[5], y[5],a[5],b[5];
   while(cin>>x[0]>>y[0] >> x[1] >> y[1] >> x[2] >> y[2] >> x[3] >> y[3])
    {
       for (i = 0; i < 4; i++)
       {
           a[i] = x[i ];
           b[i] = y[i ];
       }
       sort(x, x + 4); sort(y, y + 4);
       cout << fixed << setprecision(2);
       if (min(a[0],a[1]) <= max(a[2],a[3]) && 
           min(a[2],a[3]) <= max(a[0],a[1]) && 
           min(b[0],b[1]) <= max(b[2],b[3]) && 
           min(b[2],b[3]) <= max(b[0],b[1]))
           cout << (x[2] - x[1]) * (y[2] - y[1]) << endl;
       else
           cout << 0.00 << endl;
    }
    return 0;
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值