SDUTOJ 2444 - 正方形

Problem Description

给出四个点,判断这四个点能否构成一个正方形。

Input

输入的第一行包含一个整数T(T≤30)表示数据组数,每组数据只有一行,包括8个整数x1, y1, x2, y2,x3,y3,x4,y4(数据均在-1000,1000 之间)以逆时针顺序给出四个点的坐标。

Output

每组数据输出一行,如果是正方形,则输出: YES, 否则,输出:NO。

Sample Input

2
0 0 1 0 1 1 0 1
-1 0 0 -2 1 0 2 0

Sample Output

YES
NO

Hint
Source

思路:
判定四条边相等,且使用勾股定理判定对角线与边的关系

package hello;

import java.util.*;
import java.lang.*;

class point{
	int x, y;
	public point(int x, int y) {
		this.x = x;
		this.y = y;
	}
	
	public int dis(point p) {
		return (x-p.x)*(x-p.x)+(y-p.y)*(y-p.y);
	}
}

public class Main {
	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		int T = sc.nextInt();
		while(T > 0) {
			T--;
			point a = new point(sc.nextInt(), sc.nextInt()); // 四个点
			point b = new point(sc.nextInt(), sc.nextInt());
			point c = new point(sc.nextInt(), sc.nextInt());
			point d = new point(sc.nextInt(), sc.nextInt());
			
			int dis1 = a.dis(b); // 四条边的长度的平方
			int dis2 = b.dis(c);
			int dis3 = c.dis(d);
			int dis4 = d.dis(a);
			
			int dis5 = a.dis(c); // 对角线长度的平方
			
			if (dis1 == dis2&&dis2 == dis3&&dis3 == dis4&&dis1+dis2 == dis5) { // 判定正方形
				System.out.println("YES");
			}
			else {
				System.out.println("NO");
			}
		}
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值