Problem Description
Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single line with several words. There will be at most 1000 characters in a line.
Output
For each test case, you should output the text which is processed.
Sample Input
3
olleh !dlrow
m’I morf .udh
I ekil .mca
Sample Output
hello world!
I’m from hdu.
I like acm.
Hint
Remember to use getchar() to read ‘\n’ after the interger T, then you may use gets() to read a line and process it.
解题思路
选择栈,考虑出栈条件为每行结束(即’\n’)、每个单词结束(即’ ')、输入结束(即EOF)。
#include <bits/stdc++.h>
using namespace std;
int main()
{
int n;
char ch;
scanf("%d", &n);
getchar(); // 提示吃掉数字后面输入的回车(‘\n’)
while(n--)
{
stack<char> s;
while(true)
{
scanf("%c", &ch);
if (ch == '\n' || ch == EOF || ch ==' ')
{
while(!s.empty())
{
printf("%c", s.top());
s.pop();
}
if (ch == ' ')
{
printf(" ");
}
if (ch == '\n' || ch == EOF) // 到每行结尾结束输入
0 {
printf("\n");
break;
}
}
else
{
s.push(ch);
}
}
}
return 0;
}