POJ1979 Red and Black(dfs求连通块(的个数))

2 篇文章 0 订阅

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

‘.’ - a black tile
‘#’ - a red tile
‘@’ - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
…#.
…#





#@…#
.#…#.
11 9
.#…
.#.#######.
.#.#…#.
.#.#.###.#.
.#.#…@#.#.
.#.#####.#.
.#…#.
.#########.

11 6
…#…#…#…
…#…#…#…
…#…#…###
…#…#…#@.
…#…#…#…
…#…#…#…
7 7
…#.#…
…#.#…
###.###
…@…
###.###
…#.#…
…#.#…
0 0

Sample Output

45
59
6
13

Solution

https://blog.csdn.net/NoMasp/article/details/50240483参考文献
这么多年过去了,这个人还是分不清方向。好像回到了去年十月看ppt的时候

AC代码

#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;
char a[30][30];
int w,h;
int sum=0;
int dx[4]={1,-1,0,0},dy[4]={0,0,1,-1};
int dfs(int x,int y)
{
    a[x][y]='#';
    ++sum;
    for(int i=0;i<4;++i)
    {
        int xx=x+dx[i];
        int yy=y+dy[i];
        if(xx>=1&&xx<=h&&yy>=1&&yy<=w&&a[xx][yy]!='#') dfs(xx,yy);
    }
    return sum;
}
int main()
{
    while(scanf("%d %d",&w,&h)!=EOF&&w!=0&&h!=0)
    {
        char x,y;
        for(int i=1;i<=h;++i)
        {
            getchar();
            for(int j=1;j<=w;++j)
            {
                scanf("%c",&a[i][j]);
                if(a[i][j]=='@')
                {
                    x=i;
                    y=j;
                }
            }
        }
        printf("%d\n",dfs(x,y));
        sum=0;
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值