HDU-Red and Black- 走方砖

29 篇文章 0 订阅
问题及代码:

Problem B Red and Black

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 10   Accepted Submission(s) : 5
Font: Times New Roman | Verdana | Georgia
Font Size:  

Problem Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). 

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13


/*    
*Copyright (c)2015,烟台大学计算机与控制工程学院    
*All rights reserved.    
*文件名称:HDU.cpp    
*作    者:单昕昕    
*完成日期:2015年2月25日    
*版 本 号:v1.0        
*/ 
#include<iostream>
#include<cstring>
using namespace std;
char s[21][21];
int f(int m,int n,int row,int line);
int main()
{
    int row,line,i,j,m,n;
    while(cin>>line>>row&&(row!=0)&&(line!=0))
    {
        int count=0;
        memset(s,'#',sizeof(s));
        for(i=0; i<row; i++)
            for(j=0; j<line; j++)
            {
                cin>>s[i][j];
                if(s[i][j]=='@')
                {
                    m=i;
                    n=j;
                }
            }
        count=f(m,n,row,line);
        cout<<++count<<endl;
    }
    return 0;
}
int f(int m,int n,int a,int b)
{
    int count=0;
    if(m>0)
        if(s[m-1][n]=='.')
        {
            count++;
            s[m-1][n]='#';
            count+=f(m-1,n,a,b);
        }
    if(n>0)
        if(s[m][n-1]=='.')
        {
            count++;
            s[m][n-1]='#';
            count+=f(m,n-1,a,b);
        }
    if(m<a)
        if(s[m+1][n]=='.')
        {
            count++;
            s[m+1][n]='#';
            count+=f(m+1,n,a,b);
        }
    if(n<b)
        if(s[m][n+1]=='.')
        {
            count++;
            s[m][n+1]='#';
            count+=f(m,n+1,a,b);
        }
    return count;
}



运行结果:



知识点总结:

递归搜索。


学习心得:

死在一个小细节上!!!然后WA了5次!!!我要哭死了!!!!!

一定要注意,题目上说W and H are not more than 20,但是数组定义要写成[21][21]!!!我写成20了!!!

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值