POJ2456(二分/最大化最小值)

7 篇文章 0 订阅

Description

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,…,xN (0 <= xi <= 1,000,000,000).

His C (2 <= C <= N) cows don’t like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

Input

  • Line 1: Two space-separated integers: N and C

  • Lines 2…N+1: Line i+1 contains an integer stall location, xi

Output

  • Line 1: One integer: the largest minimum distance

Sample Input

5 3
1
2
8
4
9

Sample Output

3

Solution

二分枚举区间,然后贪心就完事了
需要注意的地方:
·开long long
·从第二个开始贪心
·注意把mid定义在外面
没了

AC代码

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cmath>
#define ll long long
using namespace std;
int n,c;
//int arr;
ll a[100005];
bool judge(ll s)
{
    ll step=1;
    ll start=a[1];
    //int end=start+s;
    for(ll i=2;i<=n;++i)
    {
        if(a[i]-start>=+s)
        {
            start=a[i];
            ++step;
            //printf("//%d %d\n",start,end);
        }
    }
    return step>=c;
}
int main()
{
    while(~scanf("%d %d",&n,&c))
    {
        for(int i=1;i<=n;++i)
        {
            scanf("%lld",&a[i]);
        }
        sort(a+1,a+1+n);
        //arr=a[n];
        //int ans;
        ll up=a[n];
        ll down=0;
        ll mid;
        while((up-down)>1)
        {
            mid=(up+down)/2;
            //printf("%d\n%d %d\n",mid,up,down);
            if(judge(mid)==1)
            {
                down=mid;
            }
            else up=mid;
            //ans=mid;
        }
        printf("%lld\n",up-1);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值