【剑指紫金港】1064 Complete Binary Search Tree 填空完全二叉搜索树

17 篇文章 0 订阅
12 篇文章 0 订阅

A 1064 Complete Binary Search Tree

题目链接

Problem Description

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node’s key.
The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
Both the left and right subtrees must also be binary search trees.
A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input

Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:

10
1 2 3 4 5 6 7 8 9 0

Sample Output:

6 3 8 1 5 7 9 0 2 4

题目大意

给出n个节点的值,将这n个节点组成一颗完全二叉搜索树,输出这颗树的层次遍历。

解题思路

将样例的树画出来,对n个节点的值排序。根据完全二叉树节点i的左儿子是2i+1、右儿子是2i+2的性质,想办法把n个节点按照顺序填入层次遍历结果数组中。具体参照dfs函数感悟。

AC代码

#include<bits/stdc++.h>
using namespace std;

const int maxn = 1005;

int tree[maxn],ans[maxn],n,cnt=0;

void dfs(int x){
    if(x>=n) return;
    dfs(2*x+1);
    ans[x]=tree[cnt++];
    dfs(2*x+2);
}

int main(){
    scanf("%d",&n);
    for(int i=0;i<n;i++){
        scanf("%d",&tree[i]);
    }
    sort(tree,tree+n);
    dfs(0);
    for(int i=0;i<n;i++){
        if(i>0){
            printf(" ");
        }
        printf("%d",ans[i]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

征服所有不服

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值