【剑指紫金港】1099 Build A Binary Search Tree 根据BST的结构求层序

A 1099 Build A Binary Search Tree

题目链接

Problem Description

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node’s key.
The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
Both the left and right subtrees must also be binary search trees.
Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.
在这里插入图片描述

Input

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100) which is the total number of nodes in the tree. The next N lines each contains the left and the right children of a node in the format left_index right_index, provided that the nodes are numbered from 0 to N−1, and 0 is always the root. If one child is missing, then −1 will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.

Output

For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

9
1 6
2 3
-1 -1
-1 4
5 -1
-1 -1
7 -1
-1 8
-1 -1
73 45 11 58 82 25 67 38 42

Sample Output:

58 25 82 11 38 67 45 73 42

题目大意

n个节点构成一颗二叉搜索树,输入n个节点的左孩子和右孩子节点,以及n个节点的值。复原这颗二叉树,然后输出它的层次遍历。

解题思路

将所有节点值从小到大排序,然后从根节点dfs深度优先搜索整颗树,在搜完左子树后,搜右子树前给根节点赋值,保证了左边的节点一定小于右边。然后bfs输出层序序列。

AC代码

#include<bits/stdc++.h>
using namespace std;
#define INF 0x3f3f3f3f
const int maxn = 105;

struct node{
    int data,l,r;
}tree[maxn];

int w[maxn],n,lchild,rchild,cnt=0,ind=0;

void dfs(int root){
    if(tree[root].l!=-1){
        dfs(tree[root].l);
    }
    tree[root].data=w[ind++];
    if(tree[root].r!=-1){
        dfs(tree[root].r);
    }
}

void bfs(){
    queue<node>q;
    q.push(tree[0]);
    while(!q.empty()){
        node now=q.front();
        q.pop();
        if(cnt>0) printf(" ");
        printf("%d",now.data);
        cnt++;
        if(now.l!=-1){
            q.push(tree[now.l]);
        }
        if(now.r!=-1){
            q.push(tree[now.r]);
        }
    }
    return ;
}

int main(){
    scanf("%d",&n);
    for(int i=0;i<n;i++){
        scanf("%d%d",&lchild,&rchild);
        tree[i].l=lchild;
        tree[i].r=rchild;
    }
    for(int i=0;i<n;i++){
        scanf("%d",&w[i]);
    }
    sort(w,w+n);
    dfs(0);
    bfs();
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

征服所有不服

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值