Wireless Network -并查集水题

Description

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B. 

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations. 

Input

The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats: 
1. "O p" (1 <= p <= N), which means repairing computer p. 
2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate. 

The input will not exceed 300000 lines. 

Output

For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.

Sample Input

4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4

Sample Output

FAIL
SUCCESS

Source

POJ Monthly,HQM

题意:n组数据和两地之间不能超过多少米开始n行是n个数的坐标后面是开头S询问能不能联通0是联通和哪一个联通

思路:for循环跑出每点距离已知的并查集并起来然后0就是把他和其他并起来如果s求出是否并

代码如下:

#include<iostream>
#include<cstring>
#include<cmath>
#include<cstdio>
using namespace std;
struct node{
	double x,y;bool a;
}pp[100009];
double map1[1009][1009];
int f[1000009];
int find(int x)
{
	if(x == f[x])
	{
		return x;
	}
	else{
		return f[x] = find(f[x]);
	}
}
int unon(int x,int y)
{
	x = find(x);
	y = find(y);
	if(x == y)
	{
		return 1;
	}
	else{
		f[x] = y;
		return 0;
	}
}
int main()
{
	int n,d;
	while(~scanf("%d%d",&n,&d))
	{
		memset(pp,0,sizeof(pp));
		memset(map1,0,sizeof(map1));
		for(int i=0;i<=n;++i)
		{
			f[i] = i;
		}
		for(int i = 1;i <= n;++i)
		{
			scanf("%lf %lf",&pp[i].x,&pp[i].y);
			pp[i].a = false;
		}
		for(int i = 1;i <= n;++i)
		{
			for(int j = 1;j <= n;++j)
			{
				map1[i][j] = sqrt((pp[i].x-pp[j].x)*(pp[i].x-pp[j].x)+(pp[i].y-pp[j].y)*(pp[i].y-pp[j].y));
			}
		}
		char c;
		while(cin>>c)
		{
			int ff;
			if(c == 'O')
			{
				scanf("%d",&ff);
				pp[ff].a = true;
				for(int i=1;i<=n;++i)
				{
					if(pp[i].a == true && map1[ff][i] <= d)
					{
						unon(ff,i);
					}
				}
			}
			else{
				int y,v;
				scanf("%d%d",&y,&v);
				if(find(y) == find(v))
				{
					printf("SUCCESS\n");
				}
				else{
					printf("FAIL\n");
				}
			}
		}
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

-lyslyslys

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值