Oulipo -kmp模板

57 篇文章 0 订阅

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

  • One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
  • One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output

1
3
0
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<stack>
#include<queue>
#include<bitset>
#include<set>
#include<map>
#define inf 0x3f3f3f3f
#define ll long long
#define pi acos(-1)
using namespace std;
char mo[1000009];
int next1[1000009];
char str[1000009];
void getnext()
{
	next1[0] = -1;
	int i = 0,j = -1;
	int len = strlen(mo);
	while(i < len)
	{
		if(j == -1 || mo[i] == mo[j])//如果是第一次或要进行的和他前面的指定位置相同 
		{
			i++;
			j++;//主串和副串一起前进 
			next1[i] = j;//记录匹配长度 
		}
		else{
			j = next1[j];//不行找他记录的上一个可以匹配到的 
		}
	}
}//对模式串进行操作 
int kmp()
{
	int ans = 0;
	int i = 0,j = 0;
	int len1 = strlen(mo);
	int len2 = strlen(str);
	while(i < len2)
	{
		if(mo[j] == str[i] || j == -1)
		{
			i++;j++;
		}
		else{
			j = next1[j];
		}
		if(j == len1)
		{//这里是找到匹配位置的地方,i存在主串的位置用时搞就行 
			ans++;//记录有几次匹配 
			j = next1[j]; //继续执行 
		}
	}
	return ans;//返回几次 
}
int main()
{
	int n;
	scanf("%d",&n);
	while(n--)
	{
		scanf("%s",&mo);//存好模式串 
		scanf("%s",&str);//主串(最长的 ) 
		getnext();//搞出next数组 
		printf("%d\n",kmp());//kmp输出主串中有几个匹配串 
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

-lyslyslys

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值