链式前向星存图-dinic

Network flow is a well-known difficult problem for ACMers. Given a graph, your task is to find out the maximum flow for the weighted directed graph.

Input

The first line of input contains an integer T, denoting the number of test cases. 
For each test case, the first line contains two integers N and M, denoting the number of vertexes and edges in the graph. (2 <= N <= 15, 0 <= M <= 1000) 
Next M lines, each line contains three integers X, Y and C, there is an edge from X to Y and the capacity of it is C. (1 <= X, Y <= N, 1 <= C <= 1000)

Output

For each test cases, you should output the maximum flow from source 1 to sink N.

Sample Input

2
3 2
1 2 1
2 3 1
3 3
1 2 1
2 3 1
1 3 1

Sample Output

Case 1: 1
Case 2: 2
#include <iostream>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <vector>
#include <queue>
using namespace std;
#define inf 0x3f3f3f3f
#define ll long long
const int maxn = 1e2+6;
const int maxm = 2e4+10;
struct Edge{
	int from, to, cap, flow;
	Edge(){}
	Edge(int from, int to, int cap, int flow):from(from), to(to), cap(cap), flow(flow){}
};
struct dinic
{
	int n, m, s, t;//n 为节点数 m为边数 s为源点 t为汇点 
	Edge edges[maxm];
	int head[maxn], next[maxm];
	bool vis[maxn];
	int d[maxn];
	int cur[maxn];
	
	void init(int n, int s, int t)
	{
		this->n = n;
		this->s = s;
		this->t = t;
		memset(head, -1, sizeof(head));
		m = 0;	
	} 
	
	void Add_edge(int from, int to, int cap)
	{
		edges[m] = Edge(from, to, cap, 0);
		next[m] = head[from];
		head[from] = m++;
		
		edges[m] = Edge(to, from, 0, 0);
		next[m] = head[to];
		head[to] = m++;
	}
	
	bool bfs()
	{
		memset(vis, 0, sizeof(vis));
		queue<int> Q;
		Q.push(s);
		d[s] = 0;
		vis[s] = true;
		while(!Q.empty())
		{
			int x = Q.front();
			Q.pop();
			for(int i = head[x];i != -1;i = next[i])
			{
				Edge& e = edges[i];
				if(!vis[e.to] && e.cap > e.flow)
				{
					vis[e.to] = true;
					d[e.to] = d[x] + 1;
					Q.push(e.to);
				}
			}
		}
		return vis[t];
	} 
	
	int dfs(int x, int a)
	{
		if(x == t || a == 0) return a;
		int flow = 0, f;
		for(int& i = cur[x] ;i != -1;i = next[i])
		{
			Edge& e = edges[i];
			if(d[x] + 1 == d[e.to] && (f = dfs(e.to, min(a, e.cap-e.flow) ) ) > 0 )
			{
				e.flow += f;
				edges[i^1].flow -= f;
				flow += f;
				a -= f;
				if(a == 0) break;
			}
		}
		return flow;
	}
	
	int maxflow()
	{
		int flow = 0;
		while(bfs())
		{
			for(int i = 1;i <= n;++i)
			{
				cur[i] = head[i];
			}
			flow += dfs(s, inf);
		}
		return flow;
	}
}gao;
int main()
{
	int t;
	scanf("%d", &t);
	int cnt = 1;
	while(t--)
	{
		int n, m;
		scanf("%d%d", &n, &m);
		gao.init(n, 1, n);//初始化数组
		while(m--)
		{
			int u, v, w;
			scanf("%d%d%d", &u, &v, &w);
			gao.Add_edge(u, v, w);//把每边加入
		}
		printf("Case %d: %d\n",cnt++,gao.maxflow());//输出最大流
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

-lyslyslys

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值