HDU 4027 线段树区间查询更新

题目

A lot of battleships of evil are arranged in a line before the battle. Our commander decides to use our secret weapon to eliminate the battleships. Each of the battleships can be marked a value of endurance. For every attack of our secret weapon, it could decrease the endurance of a consecutive part of battleships by make their endurance to the square root of it original value of endurance. During the series of attack of our secret weapon, the commander wants to evaluate the effect of the weapon, so he asks you for help.
You are asked to answer the queries that the sum of the endurance of a consecutive part of the battleship line.
Notice that the square root operation should be rounded down to integer.

输入

The input contains several test cases, terminated by EOF.
For each test case, the first line contains a single integer N, denoting there are N battleships of evil in a line. (1 <= N <= 100000)
The second line contains N integers Ei, indicating the endurance value of each battleship from the beginning of the line to the end. You can assume that the sum of all endurance value is less than 2 63.
The next line contains an integer M, denoting the number of actions and queries. (1 <= M <= 100000)
For the following M lines, each line contains three integers T, X and Y. The T=0 denoting the action of the secret weapon, which will decrease the endurance value of the battleships between the X-th and Y-th battleship, inclusive. The T=1 denoting the query of the commander which ask for the sum of the endurance value of the battleship between X-th and Y-th, inclusive.

输出

For each test case, print the case number at the first line. Then print one line for each query. And remember follow a blank line after each test case.

样例输入

10
1 2 3 4 5 6 7 8 9 10
5
0 1 10
1 1 10
1 1 5
0 5 8
1 4 8

样例输出

Case #1:
19
7
6

思路

刚开始以为是道水题,直接套区间更新lazy模板就行了,但是发现并不能,因为区间和开根不等于区间中每个值开根的和。但是直接用单点更新的话这个数据量显然会超时…
但是我们可以发现,开根后的值是下降的很快的,而且所有的值在经历有限次开根后都会变成1,所以我们对更新进行剪枝操作,当区间和为当前区间的长度时,直接return。
要注意两个坑,一个是区间的l可能比r大,还有一个是并没有进行四舍五入。

AC代码

#include<iostream>
#include<cstdio>
#include<cmath>
using namespace std;
const int maxn=100005;
long long tree[maxn<<2];
long long w[maxn];
int N;
void build(int id,int l,int r){
	if(l==r){
		tree[id]=w[l];
		return;
	}
	int mid=(l+r)>>1;
	build(id<<1,l,mid);
	build(id<<1|1,mid+1,r);
	tree[id]=tree[id<<1]+tree[id<<1|1];
}
void update(int id,int l,int r,int a,int b){
	if(l==r){
		double k=sqrt(tree[id]);
		tree[id]=(long long)(k);
		return;
	}
	if(a<=l&&r<=b&&tree[id]==(r-l+1)){//等于区间长度时代表下面的值都为1,不需要再更新了
		return;
	} 
	int mid=(l+r)>>1;
	if(a<=mid)update(id<<1,l,mid,a,b);
	if(b>mid)update(id<<1|1,mid+1,r,a,b); 
	tree[id]=tree[id<<1]+tree[id<<1|1];
}
long long query(int id,int l,int r,int a,int b){
	if(a<=l&&r<=b){
		return tree[id];
	}
	long long ans=0;
	int mid=(l+r)>>1;
	if(a<=mid)ans+=query(id<<1,l,mid,a,b);
	if(b>mid)ans+=query(id<<1|1,mid+1,r,a,b);
	return ans;
}
int main(){
	int cnt=0;
	while(~scanf("%d",&N)){
		printf("Case #%d:\n",++cnt);
		for(int i=1;i<=N;i++){
			scanf("%lld",&w[i]);
		}
		build(1,1,N);
		int Q;
		scanf("%d",&Q);
		int x,y,z; 
		for(int i=1;i<=Q;i++){
			scanf("%d%d%d",&x,&y,&z);
			if(y>z)swap(y,z);
			if(x){
				cout << query(1,1,N,y,z) << endl;
			}
			else{
				update(1,1,N,y,z);
			}
		}
		cout << endl;
	}
	return 0;
} 
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值