POJ 3669 BFS+最优化剪枝

Description

Bessie hears that an extraordinary meteor shower is coming; reports say that these meteors will crash into earth and destroy anything they hit. Anxious for her safety, she vows to find her way to a safe location (one that is never destroyed by a meteor) . She is currently grazing at the origin in the coordinate plane and wants to move to a new, safer location while avoiding being destroyed by meteors along her way.

The reports say that M meteors (1 ≤ M ≤ 50,000) will strike, with meteor i will striking point (Xi, Yi) (0 ≤ Xi ≤ 300; 0 ≤ Yi ≤ 300) at time Ti (0 ≤ Ti ≤ 1,000). Each meteor destroys the point that it strikes and also the four rectilinearly adjacent lattice points.

Bessie leaves the origin at time 0 and can travel in the first quadrant and parallel to the axes at the rate of one distance unit per second to any of the (often 4) adjacent rectilinear points that are not yet destroyed by a meteor. She cannot be located on a point at any time greater than or equal to the time it is destroyed).

Determine the minimum time it takes Bessie to get to a safe place.

Input

  • Line 1: A single integer: M
  • Lines 2…M+1: Line i+1 contains three space-separated integers: Xi, Yi, and Ti

Output

  • Line 1: The minimum time it takes Bessie to get to a safe place or -1 if it is impossible.

Sample Input

4
0 0 2
2 1 2
1 1 2
0 3 5
Sample Output
5

Problem mean

给M个陨石的降落地点和降落时间,每个陨石降落之后会将降落地点和周围四个点毁灭,要求求出最短时间内走出的点。
注意的点:
1.虽然说x<=y<=300但是求生仍然可以走出300.
2.毁灭了的点不能再走

思路

将要被毁灭的点进行标记,记录它们要被毁灭的时间,暴力bfs,如果当前时间小于被毁灭的时间,就可以通过,否则不能通过。
由于并不是求最短路径的问题,所以不能直接用vis数组标记走过的路。
此时考虑到两个点之间重复踩的问题,如果数据量过大的话,会导致TLE,所以考虑剪枝。
剪枝思路:如果一个点通过一个在将来要被毁灭的点,那就将这个点的时间设为当前这个点要被毁灭的时间,剪掉后面的所有的路径。(整个问题的思路其实就是最快时间到一个点,如果你到一个点的用的时间是最少的,你这个肯定是最优的)。

代码

#include<iostream>
#include<map>
#include<queue>
#include<cstring>
#define INF 0x3f3f3f3f
using namespace std;
int dx[]={0,-1,0,1};
int dy[]={1,0,-1,0};
int a[1005][1005];
int maxT=0;
bool check(int x,int y){
	if(x<0||y<0||x>1000||y>1000)return false;
	return true;
}
struct Node{
	int x,y,time;
	Node(){
	}
	Node(int a,int b,int c):x(a),y(b),time(c){
	}
};
int bfs(int sx,int sy){
	Node first(sx,sy,0);
	queue<Node> que;
	if(a[sx][sy]>0)
	que.push(first);
	while(!que.empty()){
		Node temp=que.front();
		que.pop();
		if(a[temp.x][temp.y]==INF){
			return temp.time;
		}
		for(int i=0;i<4;i++){
			int tempX=temp.x+dx[i];
			int tempY=temp.y+dy[i];
			if(check(tempX,tempY)&&temp.time+1<a[tempX][tempY]){
				if(a[tempX][tempY]!=INF)a[tempX][tempY]=temp.time+1; //最优化剪枝 
				que.push(Node(tempX,tempY,temp.time+1));
			}
		}
	}
	return -1;
}
int main(){
	ios::sync_with_stdio(false);//cin优化
	int M;
	cin >> M;
	int x,y,t;
	memset(a,0x3f,sizeof a);//INF代表安全地点
	for(int i=1;i<=M;i++){
		cin >> x >> y >> t;
		a[x][y]=min(a[x][y],t);
		maxT=max(maxT,t);
		for(int j=0;j<4;j++){
			int tempX=x+dx[j];
			int tempY=y+dy[j];
			if(check(tempX,tempY)){
				a[tempX][tempY]=min(a[tempX][tempY],t);
			}
		}
	}
	cout << bfs(0,0) << endl;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值