A - Til the Cows Come Home (优先队列 + dijkstra + 链式前向星存储)

这篇博客探讨了如何使用优先队列和Dijkstra算法帮助Bessie从田地的苹果树丛返回到地标1——奶牛棚的最短路径问题。Bessie需要在农夫John唤醒她进行清晨挤奶之前尽可能快地回家,以确保充足的休息。题目描述了田地中包含N个地标和T条双向奶牛小径。通过解决这个问题,我们可以找到保证存在的最短回程距离。
摘要由CSDN通过智能技术生成

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible. 

Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it. 

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

Input

* Line 1: Two integers: T and N 

* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.

Output

* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

Sample Input

5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100

Sample Output

90

Hint

INPUT DETAILS: 

There are five landmarks. 

OUTPUT DETAILS: 

Bessie can get home by following trails 4, 3, 2, and 1.

 

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<bitset>
#include<cassert>
#include<cctype>
#include<cmath>
#include<cstdlib>
#include<ctime>
#include<deque>
#include<iomanip>
#include<list>
#include<map>
#include<queue>
#include<set>
#include<stack>
#include<vector>
#define lt k<<1
#define rt k<<1|1
using namespace std;
typedef long long ll;
typedef long double ld;
#define ios ios::sync_with_stdio(false);cin.tie(0);cout.tie(0);
#define mem(a, b) memset(a, b, sizeof(a))
const double pi = acos(-1.0);
const double eps = 1e-6;
const ll mod = 1e9 + 7;
const int inf = 0x3f3f3f3f;
const ll INF = 0x3f3f3f3f3f3f3f3f;
const int maxn = 2e3 + 5;
int head[maxn];
int cnt;
int dis[maxn];
int vis[maxn];
struct Edge
{
    int v, w, next;
}edge[maxn * 4];

struct node
{
    int v, w;
    bool operator < (const node &b) const
    {
        return w > b.w;
    }
};

void add_edge(int u, int v, int w)
{
    edge[cnt].v = v;
    edge[cnt].w = w;
    edge[cnt].next = head[u];
    head[u] = cnt++;
}
void iint()
{
    memset(dis, inf, sizeof(dis));
    memset(vis, 0, sizeof(vis));
    memset(head, -1, sizeof(head));
    cnt = 0;
}
void gsl()
{
    priority_queue<node> q;
    node s;
    dis[1] = 0;
    s.v = 1;
    s.w = dis[1];
    q.push(s);
    while(!q.empty())
    {
        node now;
        now = q.top();
        q.pop();
        int u = now.v;
        if(vis[u]) continue;
        vis[u] = 1;
        for(int i=head[u]; ~i;i=edge[i].next)
        {

            int v = edge[i].v;
            int w = edge[i].w;
            if(dis[v] > dis[u] + w)
            {
                dis[v] = dis[u] + w;
                s.v = v;
                s.w = dis[v];
                q.push(s);
            }
        }
    }
}
int main()
{
    int t, n;
    while(cin >> t >> n)
    {
        iint();
        for(int i=0;i<t;i++)
        {
            int u, v, w;
            cin >> u >> v >> w;
            add_edge(u, v, w);
            add_edge(v, u, w);
        }
        gsl();
        cout << dis[n] << endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值