01-复杂度2 Maximum Subsequence Sum (25 分)

题目链接01-复杂度2 Maximum Subsequence Sum (25 分)

Given a sequence of K integers { N
​1
​​ , N
​2
​​ , …, N
​K
​​ }. A continuous subsequence is defined to be { N
​i
​​ , N
​i+1
​​ , …, N
​j
​​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:
Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:
For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:
10
-10 1 2 3 4 -5 -23 3 7 -21
Sample Output:
10 1 4

翻译:
给定一系列K个整数, 连续子序列定义为其中1≤i≤j≤K。 最大子序列是连续子序列,其子元素的总和最大。 例如,给定序列{-2,11,-4,13,-5,-2},其最大子序列是{11,-4,13},最大和为20。

现在你应该找到最大的总和,以及最大子序列的第一个和最后一个数字。

输入规格:
每个输入文件包含一个测试用例。 每个案例占两行。 第一行包含正整数K(≤10000)。 第二行包含K个数字,用空格分隔。

输出规格:
对于每个测试用例,在一行中输出最大总和,以及最大子序列的第一个和最后一个数字。 数字必须用一个空格分隔,但在一行的末尾必须没有多余的空格。 在最大子序列不唯一的情况下,输出具有最小索引i和j的那个(如示例情况所示)。 如果所有K个数都是负数,则其最大总和定义为0,并且您应该输出整个序列的第一个和最后一个数字

题解:三种情况: 找到零的位置
1、全为负数,输出0 第一个和最后一个数字
2、只有负数和零,输出0 以及零的位置,两次,开始和结束
3、普通情况,输出最大和 以及起始和结束元素值

注意:输入时是以1开始的

#include <iostream>
#include <cstdio>
#include <string>
#include <vector>
#include <queue>
#include <ctime>
#include <cmath>
#include <algorithm>
using namespace std;
typedef long long ll;
#define maxn 100005
#define mod 7654321

int main()
{
    int a[maxn];
    int n,maxx=0,fushu=1,ling=0,pos0;
    int start,end;
    cin>>n;
    for(int i=1;i<=n;i++)
        cin>>a[i];
    for(int i=1;i<=n;i++)
    {
        if(a[i]>0)
        {
            fushu=0;
            break;
        }
    }
    for(int i=1;i<=n;i++)
    {
        if(a[i]==0)
        {
            ling=1;
            pos0=i;
            break;
        }
    }

    if(fushu&&ling==0)
    {
        cout<<0<<" "<<a[1]<<" "<<a[n]<<endl;
    }
    else if(fushu&&ling)
    {
        cout<<0<<" "<<a[pos0]<<" "<<a[pos0]<<endl;
    }
    else
    {
        for(int i=1;i<=n;i++)//左端点
        {
            int sum=0;
            for(int j=i;j<=n;j++)//右端点
            {
                sum+=a[j];//从i到j其实每次就加了一项eg:0~1 0~2....只比钱一个区间的和多加了一项
                if(maxx<sum)
                    maxx=sum,start=i,end=j;
            }
        }
        cout<<maxx<<" "<<a[start]<<" "<<a[end]<<endl;
    }

    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值