PAT A1048 Find Coins (25 分)

1048 Find Coins (25 分)

Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she could only use exactly two coins to pay the exact amount. Since she has as many as 10​5​​ coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find two coins to pay for it.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (≤10​5​​, the total number of coins) and M (≤10​3​​, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers no more than 500. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the two face values V​1​​ and V​2​​ (separated by a space) such that V​1​​+V​2​​=M and V​1​​≤V​2​​. If such a solution is not unique, output the one with the smallest V​1​​. If there is no solution, output No Solution instead.

Sample Input 1:

8 15
1 2 8 7 2 4 11 15

Sample Output 1:

4 11

Sample Input 2:

7 14
1 8 7 2 4 11 15

Sample Output 2:

No Solution

 此题是找出所有给出硬币中是否存在两枚硬币的和等于给定数额。若存在,则输出两枚硬币中第一枚硬币中最小的那一对。

方法是用一个数组a存储给定硬币,用一个哈希表hash存储满足给定硬币值小于金额的硬币数,在输入a的同时判断是否小于金额,不满足的直接舍弃。完成后按从小到大的顺序排序,然后遍历a数组,寻找m-a[i]是否存在,若存在则直接输出。特别注意给出的两枚硬币的值可能相同,不然会漏解。

参考代码如下:

#include <cstdio>
#include <algorithm>
using namespace std; 
int a[100010];
int hash[10010]={0};
int main()
{
	int n,m;
	while(scanf("%d",&n)!=EOF)
	{
		scanf("%d",&m);
		for(int i=0;i<n;++i)
		{
			scanf("%d",&a[i]);
			if(a[i]<m)
				hash[a[i]]++;
		}
		sort(a,a+n);
		bool flag=true;
		for(int i=0;i<n;++i)
		{
			int k=m-a[i];
			if(hash[k])
			{
				if(k!=a[i])
				{
					printf("%d %d\n",a[i],m-a[i]);
					flag=false;
					break;
				}
				else if(k==a[i])
				{
					if(--hash[k]>0)
					{
						printf("%d %d\n",a[i],m-a[i]);
						flag=false;
						break;
					}
				}
			}	
		}
		if(flag)
			printf("No Solution\n");
	}
	return 0;
}

2.二分法查找:

#include <cstdio>
#include <algorithm>
using namespace std; 
int a[100010];
int bin(int l,int r,int x)
{
	int mid;
	while(l<=r)
	{
		mid=(l+r)/2;
		if(a[mid]==x)
			return mid;
		else if(a[mid]>x)
			r=mid-1;
		else
			l=mid+1;
	}
	return -1;
}
int main()
{
	int i,n,m;
	scanf("%d%d",&n,&m);
	for(i=0;i<n;++i)
		scanf("%d",&a[i]);
	sort(a,a+n);
	bool flag=true;
	for(i=0;i<n;++i)
	{
		int ans=bin(i,n-1,m-a[i]);
		if(ans!=-1&&ans!=i)
		{
			printf("%d %d\n",a[i],a[ans]);
			flag=false;
			break;
		}	
	}
	if(flag)
		printf("No Solution\n");
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值