4.6 PAT A1029 Median (25 分)(two pointers)

1029 Median (25 分)

Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1 = { 11, 12, 13, 14 } is 12, and the median of S2 = { 9, 10, 15, 16, 17 } is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

Given two increasing sequences of integers, you are asked to find their median.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (≤2×10​5​​) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int.

Output Specification:

For each test case you should output the median of the two given sequences in a line.

Sample Input:

4 11 12 13 14
5 9 10 15 16 17

Sample Output:

13

题意为寻找中位数,即有序序列中处在中间位置的数。此题可以将两个数组归并为一个数组然后寻找中位数,也可以设置两个指针,按归并的方法 让指针移动,直至元素个数达到中位数的位置,然后输出两个指针所指较小的值。

参考代码如下:

#include <cstdio>
const int INF=10000000;//int 上限,防止越界! 
int a[1000010],b[1000010];
int main()
{
	int n1,n2;
	while(scanf("%d",&n1)!=EOF)
	{
		for(int i=0;i<n1;++i)
			scanf("%d",&a[i]);
		scanf("%d",&n2);
		for(int i=0;i<n2;++i)
			scanf("%d",&b[i]);
		a[n1]=INF;//防止某个数组扫描完而count未达到mid而越界! 
		b[n2]=INF;
		int i1=0,i2=0;
		int mid=(n1+n2-1)/2,count=0;//-1是因为下标从0开始,需要向下取整。
		while(count<mid)
		{
			if(a[i1]<b[i2])
				i1++;
			else
				i2++;
			count++;	
		}
		if(a[i1]<b[i2])
			printf("%d\n",a[i1]);
		else
			printf("%d\n",b[i2]);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值