7.3 PAT A1052 Linked List Sorting (25 分)(静态链表的应用)

1052 Linked List Sorting (25 分)

A linked list consists of a series of structures, which are not necessarily adjacent in memory. We assume that each structure contains an integer key and a Next pointer to the next structure. Now given a linked list, you are supposed to sort the structures according to their key values in increasing order.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive N (<10​5​​) and an address of the head node, where N is the total number of nodes in memory and the address of a node is a 5-digit positive integer. NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Key Next

where Address is the address of the node in memory, Key is an integer in [−10​5​​,10​5​​], and Next is the address of the next node. It is guaranteed that all the keys are distinct and there is no cycle in the linked list starting from the head node.

Output Specification:

For each test case, the output format is the same as that of the input, where N is the total number of nodes in the list and all the nodes must be sorted order.

Sample Input:

5 00001
11111 100 -1
00001 0 22222
33333 100000 11111
12345 -1 33333
22222 1000 12345

Sample Output:

5 12345
12345 -1 00001
00001 0 11111
11111 100 22222
22222 1000 33333
33333 100000 -1

题意为给出n个结点的信息,按其data域排序后输出。注意最后一个结点输出-1.需要一个flag域将无效结点移至链表尾。利用hash静态链表模拟即可。

参考代码如下:

#include <iostream>
#include <algorithm>
using namespace std;
struct Node{
	int key;
	int address;
	int next;
	bool flag;
}node[100010];
bool cmp(Node a,Node b)
{
	if(a.flag==false||b.flag==false)
	{
		return a.flag>b.flag; //将无效结点移至链表尾 
	}
	else
		return a.key<b.key;
}
int main()
{
	
	int n,head;
	while(scanf("%d%d",&n,&head)!=EOF)
	{
		for(int i=0;i<100010;++i)
			node[i].flag=false; //初始化
		int address,data,next;
		for(int i=0;i<n;++i)
		{
			scanf("%d%d%d",&address,&data,&next);
			node[address].address=address;
			node[address].key=data;
			node[address].next=next;
		}
		int count =0,p=head;//枚举链表,对flag进行标记,同时计数有效结点个数 
		while(p!=-1)
		{
			node[p].flag=true;
			count++;
			p=node[p].next;
		}
		if(count==0) //特判,新链表中没有结点时输出0  -1 
			printf("0 -1\n");
		else
		{//筛选有效结点,并按key从小到大排序 
			sort(node,node+100010,cmp) ;
			printf("%d %05d\n",count,node[0].address);
			for(int i=0;i<count;++i)
			{
				if(i!=count-1)
					printf("%05d %d %05d\n",node[i].address,node[i].key,node[i+1].address);//next处必须为i+1!.address! 
				else
					printf("%05d %d -1\n",node[i].address,node[i].key);
			 } 
		} 
	}
	return 0;
 } 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值