问题 D: 二叉树遍历
题目描述
编一个程序,读入用户输入的一串先序遍历字符串,根据此字符串建立一个二叉树(以指针方式存储)。
例如如下的先序遍历字符串:
ABC##DE#G##F###
其中“#”表示的是空格,空格字符代表空树。建立起此二叉树以后,再对二叉树进行中序遍历,输出遍历结果。
输入
输入包括1行字符串,长度不超过100。
输出
可能有多组测试数据,对于每组数据,
输出将输入字符串建立二叉树后中序遍历的序列,每个字符后面都有一个空格。
每个输出结果占一行。
样例输入
a#b#cdef#####
a##
样例输出
a b f e d c
a
给定先序序列的数组存储形式,不借助中序序列递归建立二叉树,再中序遍历。
实质上给出的是二叉树的类似于完全二叉树的顺序存储结构——数组形式,利用这种结构可以建立二叉树。
参考代码:
#include <cstdio>
#include <cstring>
using namespace std;
struct node {
char data;
node* lchild;
node* rchild;
};
char pre[101];
int index;
node* create()
{
if(pre[index]=='#')
{
index++; //指针前移
return NULL;//返回空结点
}
node* root=new node; //非空,建立结点
root->data=pre[index];
index++; //别忘了建立一个结点指针前移!
root->lchild=create();//递归建立左子树
root->rchild=create();//递归建立右子树
return root;
}
void inorder(node* root)
{
if(root==NULL)
return ;
inorder(root->lchild);
printf("%c ",root->data);
inorder(root->rchild);
}
int main()
{
while(scanf("%s",pre)!=EOF)
{
index=0;
node*root=create();
inorder(root);
printf("\n");
}
return 0;
}