PAT A1043 Is It a Binary Search Tree (25 分)(二叉排序树的建立及先后序遍历)

1043 Is It a Binary Search Tree (25 分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.

Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in a line YES if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or NO if not. Then if the answer is YES, print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

7
8 6 5 7 10 8 11

Sample Output 1:

YES
5 7 6 8 11 10 8

Sample Input 2:

7
8 10 11 8 6 7 5

Sample Output 2:

YES
11 8 10 7 5 6 8

Sample Input 3:

7
8 6 8 5 10 9 11

Sample Output 3:

NO

题意为给定一个序列,以此为依据建立二叉树,判断此树是否是二叉排序树或镜像二叉排序树(即将每个根节点的左右子树调换,使右子树小于根结点,左子树大于根节点的二叉树)若满足这两种情况,则输出“YES”,并输出对应的后序遍历序列。

用vector分别将原始序列origin,先序pre,镜像树先序preM,后序post,镜像树后序postM存储起来,最后比较是否相等。

参考代码:

#include <cstdio>
#include <vector>
using namespace std;
struct node{
	int data;
	node *left,*right;
};
void insert(node* &root,int data)
{
	if(root==NULL) //到达空结点时,即为插入位置 
	{
		root=new node;
		root->data=data;
		root->left=root->right=NULL; //将新结点左右子树置空 
		return ;
	}
	if(data<root->data)
		insert(root->left,data); //插在左子树 
	else
		insert(root->right,data);//插入右子树 
}

void preorder(node* root,vector<int>&vi)//先序遍历,结果存在vi
{
	if(root==NULL)
		return;
	vi.push_back(root->data);
	preorder(root->left,vi);
	preorder(root->right,vi);
}

//镜像树先序遍历,结果存放于vi
void preorderM(node* root,vector<int> &vi)
{
	if(root==NULL)
		return;
	vi.push_back(root->data);
	preorderM(root->right,vi); //先遍历右子树 
	preorderM(root->left,vi);
 } 
 
void postorder(node* root,vector<int> &vi) //后序遍历
{
	if(root==NULL)
		return;
	postorder(root->left,vi);
	postorder(root->right,vi);
	vi.push_back(root->data);
}
//镜像树的后序遍历
void postorderM(node* root,vector<int> &vi)
{
	if(root==NULL)
		return;
	postorderM(root->right,vi);
	postorderM(root->left,vi);
	vi.push_back(root->data);
}

vector<int> origin,pre,preM,post,postM;
int main()
{
	int n,data;
	node* root=NULL; //定义头结点 
	scanf("%d",&n);
	for(int i=0;i<n;++i)
	{
		scanf("%d",&data);
		origin.push_back(data);
		insert(root,data); //将data插入二叉树 
	}
	preorder(root,pre);
	preorderM(root,preM);
	postorder(root,post);
	postorderM(root,postM);
	if(origin==pre) //初始序列等于先序序列 
	{
		printf("YES\n");
		for(int i=0;i<post.size();++i)
		{
			printf("%d",post[i]);
			if(i<post.size()-1)
				printf(" ");
		}
	}
	else if(origin==preM) //初始序列等于镜像树先序序列 
	{
		printf("YES\n");
		for(int i=0;i<postM.size();++i)
		{
			printf("%d",postM[i]);
			if(i<postM.size()-1)
				printf(" ");
		}
	}
	else
	{
		printf("NO\n");
	}
	return 0;
}

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值