3.1 PAT A1009 Product of Polynomials (25分)(多项式乘法)

1009 Product of Polynomials (25分)

This time, you are supposed to find A×BA\times BA×B where AAA and BBB are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

KKK N1N_1N​1​​aN1a_{N_1}a​N​1​​​​N2N_2N​2​​aN2a_{N_2}a​N​2​​​​ ... NKN_KN​K​​aNKa_{N_K}a​N​K​​​​

where KKK is the number of nonzero terms in the polynomial, NiN_iN​i​​ and aNia_{N_i}a​N​i​​​​ (i=1,2,⋯,Ki=1, 2, \cdots , Ki=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤101\le K \le 101≤K≤10, 0≤NK<⋯<N2<N1≤10000 \le N_K < \cdots < N_2 < N_1 \le 10000≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the product of AAA and BBB in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 3 3.6 2 6.0 1 1.6

此题是多项式乘法,利用一个双重循环即可求解,里面有几个坑需要注意。 

参考代码1:

#include <cstdio>
double a[1010]={0.0};
double b[1010]={0.0};
double ans[2020]={0.0};
int main()
{
	int k,e;
	double n;
	scanf("%d",&k);
	for(int i=0;i<k;++i)
	{
		scanf("%d %lf",&e,&n);
		a[e]=n;
	}
	scanf("%d",&k);
	for(int i=0;i<k;++i)
	{
		scanf("%d %lf",&e,&n);
		b[e]=n;
	}
	int count=0;
	for(int i=0;i<=1000;++i) //遍历求解 
	{
		//if(a[i]!=0.0) //不能在这里判断,否则会漏项! 
		for(int j=0;j<=1000;++j)
		{
			//if(b[j]!=0.0)
			ans[i+j]+=a[i]*b[j]; //计算乘积:指数相加,系数相乘。注意是需要累计的!
		}
	}
	for(int i=0;i<=2000;++i)
	{
		if(ans[i]!=0.0)
			count++;
	} 
	printf("%d",count);
	for(int i=2000;i>=0;--i) //别忘了倒着输出 
	{
		if(ans[i] !=0.0)
			printf(" %d %.1f",i,ans[i]);
	}
	return 0;
}

 

#include <cstdio>
double a[1010]={0.0};
double ans[2020]={0.0};
int main()
{
	int k, e,count =0 ;
    double p;
    scanf("%d",&k);
    for(int i=0; i<k;i++)
    {
        scanf("%d%lf",&e,&p);
        a[e] = p;
    }
    scanf("%d",&k);
    for(int i=0; i<k;i++)
    {
        scanf("%d%lf",&e,&p);
        for(int j=0;j<1010;j++)   // 直接计算,减少循环
        {
            ans[j+e] += p*a[j];  // 注意是+= 一定要把之前ans中的加上
            // if(ans[i]!=0)
                //count ++ ;  不能在内部计数,否则会多记数!
        }
    }
    for (int i=0;i<2010; i++)
    {
        if(ans[i]!=0)
            count ++ ;
    }
    printf("%d", count);
    for(int i=2019; i>=0; i-- )
    {
        if (ans[i]!=0)
            printf(" %d %.1f",i,ans[i]);
    }
	return 0;
}

也可利用结构体简化代码:

#include <iostream>

using namespace std;
struct poly
{
	int exp;
	double cof;
 } poly[1001];
double ans[2002]={0.0};
int main()
{
	int k,n,count =0;
	scanf("%d",&k);
	for(int i=0;i<k;++i)
	{
		scanf("%d %lf",&poly[i].exp,&poly[i].cof);
	}
	scanf("%d",&n);
	for(int i=0;i<n;++i)
	{
		int exp;
		double cof;
		scanf("%d %lf",&exp,&cof);
		for(int j=0;j<n;++j)
		{
			ans[exp+poly[j].exp]+=(cof*poly[j].cof);
		}
	}
	
	for(int i=0;i<=2000;++i)
	{
		if(ans[i]!=0.0)
		{
			count ++;
		}
	}
	printf("%d",count);
	for(int i=2000;i>=0;--i)
	{
		if(ans[i]!=0.0)
		{
			printf(" %d %.1f",i,ans[i]);
		}
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值