3.5 PAT A1058 A+B in Hogwarts (20分)(进制转换)

1058 A+B in Hogwarts (20分)

If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it's easy enough." Your job is to write a program to compute A+B where A and B are given in the standard form of Galleon.Sickle.Knut (Galleon is an integer in [0,10​7​​], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:

Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input.

Sample Input:

3.2.1 10.16.27

 

Sample Output:

14.1.28

 题意为求不同进制的a+b。

首先贴出我差一组未通过的代码,利用全部换算为knut,然后输出。我认为逻辑什么的应该都对,就是不知道哪里出了问题,有一组测试未能通过。求大神指正。

未能AC代码:

#include<cstdio>
const int gallon=17*29;
const int sickle=29;
int main()
{
	int g1,s1,k1,g2,s2,k2;
	while(scanf("%d.%d.%d %d.%d.%d",&g1,&s1,&k1,&g2,&s2,&k2)!=EOF)
	{
		long long sum=g1*gallon+s1*sickle+k1+g2*gallon+s2*sickle+k2;
		printf("%d.%d.%d\n",sum/gallon,sum%gallon/sickle,sum%sickle);
	}
	return 0;
}

利用进位,模拟加法,每位计算。

AC代码:

#include <cstdio>
int a[3],b[3],c[3];
int main()
{
	while(scanf("%d.%d.%d %d.%d.%d",&a[0],&a[1],&a[2],&b[0],&b[1],&b[2])!=EOF)
	{
		int carry=0;
		c[2]=(a[2]+b[2])%29; //获得2号位的结果 
		carry=(a[2]+b[2])/29;  //进位
		c[1]=(a[1]+b[1]+carry)%17;//获得1号位的结果
		carry=(a[1]+b[1]+carry)/17;//进位
		c[0]=(a[0]+b[0]+carry);//获得0号位的结果
		printf("%d.%d.%d",c[0],c[1],c[2]);
	}
	return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值