[PAT A1058] A+B in Hogwarts

该程序接收两个整数a和b,计算它们的和,然后以每三位一组、用逗号分隔的格式输出结果。如果结果为负数,会先输出负号;若结果为0,则直接输出0。代码使用C++编写,通过数组存储和的每一位,并动态处理逗号的插入位置。
摘要由CSDN通过智能技术生成

题目

Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:
Each input file contains one test case. Each case contains a pair of integers a and b where − 1 0 6 10^6 106≤a,b≤ 1 0 6 10^6 106. The numbers are separated by a space.

Output Specification:
For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:
-1000000 9
Sample Output:
-999,991

题意

给出两个整数a、b,按照XXX,XXX,XXX的格式输出a+b。

解答

将a+b的值按位存储在数组中即可。

代码如下:

#include <cstdio>
#include <math.h>

int main(){
    int count = 0,i,a,b,temp,ans[10];
    //char ans[10];
    scanf("%d %d",&a,&b);
    temp = a + b;
    if(temp < 0) printf("-");
    else if(temp == 0) printf("0");
    temp = abs(temp);
    for(i=0;temp != 0;i++){
        ans[i] = temp % 10;
        temp /= 10;
    }
    for(i--;i >= 0;i--){
        printf("%d",ans[i]);
        if(i % 3 == 0 && i != 0) printf(",");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值