5.5 PAT A1096 Consecutive Factors (20分)(连续质因子)

1096 Consecutive Factors (20分)

Among all the factors of a positive integer N, there may exist several consecutive numbers. For example, 630 can be factored as 3×5×6×7, where 5, 6, and 7 are the three consecutive numbers. Now given any positive N, you are supposed to find the maximum number of consecutive factors, and list the smallest sequence of the consecutive factors.

Input Specification:

Each input file contains one test case, which gives the integer N (1<N<2​31​​).

Output Specification:

For each test case, print in the first line the maximum number of consecutive factors. Then in the second line, print the smallest sequence of the consecutive factors in the format factor[1]*factor[2]*...*factor[k], where the factors are listed in increasing order, and 1 is NOT included.

Sample Input:

630

 

Sample Output:

3
5*6*7

题意为求给定数中是否有一段连续整数的乘积,可以被N整除。给出最大长度及乘积。

参考代码:

#include <cstdio>
#include <cmath>
#include <algorithm>
typedef long long ll;
int main()
{
	ll n;
	while(scanf("%lld",&n)!=EOF)
	{
		ll sqr=(ll)sqrt(1.0*n);
		ll ansi=0,anslen=0; //ansi记录质因子起始位置,anslen记录区间长度 
		for(ll i=2;i<=sqr;++i) //寻找质因子 
		{
			ll temp=1,j=i;//temp记录当前整数乘积,j为连续取值 
			while(1)
			{
				temp*=j;
				if(n%temp!=0) //非因子,退出 
					break;
				if(j-i+1>anslen) //有更长の区间,更新 
				{
					ansi=i;
					anslen=j-i+1;
				}
				j++;	
			}
		}
		if(anslen==0)
			printf("1\n%lld\n",n);
		else
		{
			printf("%lld\n",anslen);
			for(ll i=0;i<anslen;++i)
			{
				printf("%lld",ansi+i);
				if(i<anslen-1)
					printf("*");
			}
			printf("\n");
		}
	}
	return 0;
 } 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值