I - Arbitrage

I - Arbitrage

Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent.

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not.

Input

The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible.
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line telling whether arbitrage is possible or not in the format “Case case: Yes” respectively “Case case: No”.

Sample Input

3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0

Sample Output

Case 1: Yes
Case 2: No

题目大意:

这题是对Floyd算法的一个简单变形,就是看货币经过不同的汇率转换是否存在最后大于本身价值的情况,加入1美元可以兑换0.5英镑,1英镑可以兑换10法郎,一法郎又可以兑换0.21美元,那么最后就变成了1美元可以兑换1.05美元,这样就是经过汇率转换,最后大于了本身的价值,如果任意一种货币满足这种情况,就输出Yes否则输出No

#include<iostream>
#include<map>
#include<vector>
#include<cstdio>
 
using namespace std;

const int maxn = 1e3+5;
double e[maxn][maxn];
map<string,int>mp;	//将每一种货币看作一个点,这样方便对Floyd算法进行变形
int n,m;

void Fly()
{
	for(int k = 1 ; k <= n ; k++)
	{
		for(int i = 1 ; i <= n ; i++)
		{
			for(int j = 1 ; j <= n ; j++)
			{
				e[i][j] = max(e[i][j],e[i][k]*e[k][j]);	//选出最大的汇率
			}
		}
	}
}

int main()
{
	int cnt = 1;
	while(cin >> n)
	{
		fill(e[0],e[0]+maxn,0);
		for(int i = 1 ; i <= n ; i++)
			e[i][i] = 1; 
		if(n == 0)
			return 0;
		for(int i = 1 ; i <= n ; i++)
		{
			string s;
			cin >> s;
			mp[s] = i;
		}
		cin >> m;
		for(int i = 0 ; i < m ; i++)
		{
			string s1,s2;
			double cur;
			cin >> s1 >> cur >> s2;
			int x = mp[s1],y = mp[s2];
			e[x][y] = cur;
		}
		Fly();
		bool flag = false;
		for(int i = 1 ; i <= n ; i++)
		{
			if(e[i][i] > 1)	//如果汇率大于1就说明自身价值提升
			{
				printf("Case %d: Yes\n",cnt++);
				flag = true;
				break;
			}
		}
		if(!flag)
			printf("Case %d: No\n",cnt++);
	}
	return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

柠檬ya

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值