PAT 1029 Median

Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1 = { 11, 12, 13, 14 } is 12, and the median of S2 = { 9, 10, 15, 16, 17 } is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

Given two increasing sequences of integers, you are asked to find their median.

Sample Input:
4 11 12 13 14
5 9 10 15 16 17
Sample Output:
13
输入两个递增序列,输出所有数的中位数
vector的使用、sort排序

思路如下:

  1. 声明一个vector seq,分别将两个序列加进去
  2. sort排序,sort(seq.begin(),seq.end())
  3. 最后判奇偶,取出即可
代码如下:
#include<iostream>
#include<algorithm>
#include<vector>
using namespace std;
vector<int> seq;
int main(){
	int m,n,temp;
	cin>>m;
	for(int i=0;i<m;i++){
		cin>>temp;
		seq.push_back(temp);
	}
	cin>>n;
	for(int i=0;i<n;i++){
		cin>>temp;
		seq.push_back(temp);
	}
	sort(seq.begin(),seq.end());
	int sum = m+n;
	if(sum%2==0){
		cout<<seq[sum/2-1]<<endl; 
	}else{
		cout<<seq[sum/2]<<endl;
	}
	return 0;
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值