E-Convex【暑假训练赛5】

Description

We have a special convex that all points have the same distance to origin point.
As you know we can get N segments after linking the origin point and the points on the convex. We can also get N angles between each pair of the neighbor segments.
Now give you the data about the angle, please calculate the area of the convex

Input

There are multiple test cases.
The first line contains two integer N and D indicating the number of the points and their distance to origin. (3 <= N <= 10, 1 <= D <= 10)
The next lines contain N integers indicating the angles. The sum of the N numbers is always 360.

Output

For each test case output one float numbers indicating the area of the convex. The printed values should have 3 digits after the decimal point.

Sample Input

4 1
90 90 90 90
6 1
60 60 60 60 60 60

Sample Output

2.000
2.598

Code

//求n个腰长为d,顶角已知的等腰三角形面积
#include <iostream>
#include <cmath>
#include <cstdio>
using namespace std;
const float pi=3.14159;  //精度把握一下
float angle[15];

int main(){
    int n,d;
    while(~scanf("%d%d",&n,&d)){
        for(int i=0;i<n;i++){
            scanf("%f",&angle[i]);
            getchar();
        }
        float area=0;
        for(int i=0;i<n;i++){
            area+=(d*d*sin(angle[i]*pi/180))/2;  //正弦函数的用法,弧度
        }
        printf("%.3f\n",area);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值