hdu5979 Convex (数学题,三角形面积公式)

Problem Description

We have a special convex that all points have the same distance to origin point.
As you know we can get N segments after linking the origin point and the points on the convex. We can also get N angles between each pair of the neighbor segments.
Now give you the data about the angle, please calculate the area of the convex

Input

There are multiple test cases.
The first line contains two integer N and D indicating the number of the points and their distance to origin. (3 <= N <= 10, 1 <= D <= 10)
The next lines contain N integers indicating the angles. The sum of the N numbers is always 360.

Output

For each test case output one float numbers indicating the area of the convex. The printed values should have 3 digits after the decimal point.

Sample Input

4 1
90 90 90 90
6 1
60 60 60 60 60 60

Sample Output

2.000
2.598

题意:

一个n条边的凸多边形
每个顶点到原点的距离都相同,为d,
然后用线段吧n个点和原点相连,给出两两相邻的线段之间的夹角,求这个多边形的面积
保证角度和为360(即原点周围一圈)

输入多组n和d,对于每组案例输出面积,保留到小数点后三位

思路:

数学忘了好多,可恶。

图差不多是这样的:
在这里插入图片描述
其中d为线段长度,每条连向原点的线段是一样长的,
角度的话再图里面标了的一个,题目会给每个角度

这题要用到三角形面积公式:
S=1/2 ab sinC
a和b就是题目中给的线段长度‘d’,所以把每个三角形的面积加起来就是答案了,

然后是一些必要知识
Pi (π)=acos(-1.0)
sin函数传入的是弧度不是角度
角度弧度转化公式:弧度数/π=角度值/180°

ps:
实测计算过程要先做乘法再做除法,否则会因为精度问题吃wa

code:
#include<bits/stdc++.h>
using namespace std;
const int maxm=15;
const double pi=acos(-1.0);//pi
int a[maxm];
int main(){
    int n,d;
    while(cin>>n>>d){
        for(int i=1;i<=n;i++){
            cin>>a[i];//角度
        }
        double ans=0;
        for(int i=1;i<=n;i++){
            ans+=d*d*sin(pi*a[i]/180)/2;//  S=1/2 ab sinC
        }
        printf("%.3f\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值