Fractional decimal

Enter positive integer a,b,c, the decimal from of the output a/b,to the c-decimal point.a,b<= 1 0 6 10^6 106,c<=100.The input contains multiple sets of data,the end is marked a=b=c=0.
sample input:
1 6 4
0 0 0
sample output:
Case 1:0.1667

printf("%.cf",s);//This is not going to work

First,print the integer part and then print the fractional part.

integer:

printf("case%d %d.",++kase,a/b);

fractional:

Analog hand division.

a=a%b*10;
printf("%d",a/b);//The first digit after the decimal point

Rounding

The c bit is judged by the size of the value of the c+1 bit.

The full code is as follows

#include<stdio.h>
int main()

{
	int a,b,i,t;
	int c;
	int kase=0;
	while(scanf("%d",&a)==1)
	
	{
		
		scanf("%d",&b);
		scanf("%d",&c);
		if(a==0&&b==0&&c==0)
		{
			break;
		}
		printf("case%d %d.",++kase,a/b);
		a=a%b*10;
		for(i=1;i<c;i++)
		{
			
			printf("%d",a/b);
			a=a%b*10;
		}
	   t=a%b*10/b;
		if(t>=5){
			printf("%d",a/b+1);
		}
		else
		printf("%d",a/b);
		
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值