Example 3-2 WERTYU

A commom typing error is to place the hands on the keyboard one row to the right of the correct position.So that the input Q will becames the input W,the input J becames the input K and so on.Input a ty before typing eroor

Sample input
Q S, GOMR YPFSU/

Sample output
I AM FINE TODAY

It’s mine:

#include<stdio.h>
int main()
{
	char s[]="`1234567890-=QWERTYUIOP[]\\ASDFGHJKL;'ZXCVBNM,./";
	int c,i;
	
	while((c=getchar())!=EOF)
	{
		int k=1; 
		if(k)
		{
			
		
		for(i=0;i<strlen(s);i++)
		{	
			if(s[i]==c)
			{
			putchar(s[i-1]);
			k=!k;
			}
		
		}
	}
	
		if(k)
		{
		printf("%c",c);
		
	}
		
	}
	return 0;
}

liu:

#include<stdio.h>
int main()
{
	char s[]="`1234567890-=QWERTYUIOP[]\\ASDFGHJKL;'ZXCVBNM,./";
	int i,c;
	while((c=getchar())!=EOF)
	{
		for(i=1;s[i]&&s[i]!=c;i++);
		if(s[i])
		{
			putchar(s[i-1]);
			
		}
		else
		putchar(c);
	}
	return 0;
	}


日沉云起:


​#include<bits/stdc++.h>
using namespace std;
int main(){
    string s="`1234567890-=QWERTYUIOP[]\\ASDFGHJKL;\'ZXCVBNM,./";
    char c;
    while(~scanf("%c",&c))
        if(!isgraph(c))//isgraph(c)函数当c不是空格但是可打印字符时为真
            printf("%c",c);
        else
            printf("%c",s[s.find(c)-1]);//s.find(c)返回字符串s中字符c第一次出现的下标
    return 0;
}
————————————————
版权声明:本文为CSDN博主「日沉云起」的原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接及本声明。
原文链接:https://blog.csdn.net/richenyunqi/article/details/80991204
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值