Nine Interlinks



I -Nine Interlinks
Crawling in process... Crawling failed Time Limit:1000MS    Memory Limit:32768KB    64bit IO Format:%lld & %llu

Description

"What are you doing now?"

"Playing Nine Interlinks!"

"What is that?"

"Oh it is an ancient game played over China. The task is to get the nine rings off the stick according to some rules. Now, I have got them off, would you like to have a try to get them on?"

Input

The first line of the input contains an integer T (T <= 30), indicating the number of cases.

Each case consists of a simple integer n (1 < n < 30), which is the number of the total rings you need to get on the stick.

At the beginning, all rings are off the stick.

In each step, you can only get one ring on or off by the following rules:

1. You can get the first ring on or off freely at each step.

2. If the ith ring is on the stick, and the 1st, 2nd... (i-1)st rings are off the stick, you can get the(i+1)st ring on or off freely at each step.

Output

For each case, print in a single line the minimum number of steps you need to getn rings on the stick.

Sample Input

2
2
3

Sample Output

2
5

Hint
The first sample: 1 on, 2 on.
The second sample: 1 on, 2 on, 1 off, 3 on, 1 on. 



题意:给你n个环,都off stick,求最少多少步可以将n个环都on stick。要求,如果第i+1个环想要on/off,前i个环必须off,第i个on,第一个随便。
#include<iostream>
using namespace std;
int main()
{
	int t,n,a[35]={0,1,2};
	for(int i=3;i<31;i++)
	{
		a[i]=a[i-1]+2*a[i-2]+1;
	}
	cin>>t;
	while(t--)
	{
		cin>>n;
		cout<<a[n]<<endl;
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值