Key Set(思维)

Key Set

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 364 Accepted Submission(s): 239

Problem Description
soda has a set with integers . A set is called key set if the sum of integers in the set is an even number. He wants to know how many nonempty subsets of are key set.

Input
There are multiple test cases. The first line of input contains an integer , indicating the number of test cases. For each test case:

The first line contains an integer , the number of integers in the set.

Output
For each test case, output the number of key sets modulo 1000000007.

Sample Input
4 1 2 3 4

Sample Output
0 1 3 7
在这里插入图片描述
解析来自大神:https://blog.csdn.net/enjoying_science/article/details/47335721

#include<iostream>
#include<algorithm>
using namespace std;
long long quickpow(long long a,long long b,long long c)
{
	long long ans=1;
	a%=c;
	while(b)
	{
		if(b&1) ans=(ans*a)%c;
		b/=2;
		a=(a*a)%c;
	}
	return ans;
}
int main()
{
	int n;
	while(scanf("%d",&n)!=EOF)
	printf("%lld\n",quickpow(2,n-1,1000000007)-1);
	return 0;
}
  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值