key set

soda has a set  S S with  n n integers  {1,2,,n} {1,2,…,n}. A set is called key set if the sum of integers in the set is an even number. He wants to know how many nonempty subsets of  S S are key set.
Input
There are multiple test cases. The first line of input contains an integer  T T  (1T105) (1≤T≤105), indicating the number of test cases. For each test case: 

The first line contains an integer  n n  (1n109) (1≤n≤109), the number of integers in the set.
Output
For each test case, output the number of key sets modulo 1000000007.
Sample Input
4
1
2
3
4
Sample Output
0
1
3

7

难点在于找到规律 2^n-1

#include<cstdio>
const long long N=1e9+7;
long long power(long long a){
	long long b=2;
	long long temp = 1;
	while (a){
		if (a&1){
			temp=temp*b%N;
		}
		b = b*b%N;
		a>>=1;
	}
	return temp;
}
int main(){
	int t;
	scanf("%d",&t);
	while (t--){
		long long n;
		scanf("%lld",&n);
		n-=1;
		printf("%lld\n",power(n)-1);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值