POJ2406 Power Strings (KMP找有几个循环节)

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

 找一个串的最小循环节的个数.。

先求出next数组,然后使用长度-next【len】就是最小循环节的长度。然后特判就行。

AC代码:

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<vector>
#include<stdlib.h>
#include<queue>
#include<map>
#include<set>
#include<iomanip>
#include<math.h>
using namespace std;
typedef long long ll;
typedef double ld;
char p[1000010 ];
int m,nxt[1000010 ];

void GetNext(char* p, int nxt[])
{
	int pLen=strlen(p);
	nxt[0]=-1;
	int k=-1;
	int j=0;
	while(j<pLen)
	{
		//p[k]表示前缀,p[j]表示后缀
		if(k==-1||p[j]==p[k])
		{
			++j;
			++k;
			//较之前next数组求法,改动在下面4行
			if(p[j]!=p[k])
				nxt[j]=k; //之前只有这一行
			else
				//因为不能出现p[j] = p[ next[j ]],所以当出现时需要继续递归,k = next[k] = next[next[k]]
				nxt[j]=nxt[k];
		}
		else
		{
			k=nxt[k];
		}
	}
}

int main()
{
   while(scanf("%s",p)!=EOF)
    {
        if(p[0]=='.')
          break;
        int len=strlen(p);
        GetNext(p,nxt);
        int ans=1;
        if(!(len%(len-nxt[len])))
        ans=len/(len-nxt[len]);
        printf("%d\n",ans);
    }
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值