HDU 3336(扩展KMP)

Problem Description


It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:
s: "abab"
The prefixes are: "a", "ab", "aba", "abab"
For each prefix, we can count the times it matches in s. So we can see that prefix "a" matches twice, "ab" matches twice too, "aba" matches once, and "abab" matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For "abab", it is 2 + 2 + 1 + 1 = 6.
The answer may be very large, so output the answer mod 10007.
 

Input


The first line is a single integer T, indicating the number of test cases.
For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.
 

Output


For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.
 

Sample Input


1

4

abab
 

Sample Output


6
  给你一个串,求用该串所有前缀去 匹配本身这个串的次数 的总和。比如串abab,它的前缀有a,ab,aba,abab。那么拿这4个前缀去匹配abab自身分别有2,2,1,1个匹配点,所以总和为2+2+1+1=6。

其实这道题主要考察的就是KMP算法对next数组含义的理解

下面先简单介绍一下next数组到底是什么

也就是说next的值由部分匹配值整体向右移一位,且在第一位赋值-1后,再整体加1而成。

我们想想比如对于位置i来说,现在我们求出了f[i]的值,那么[0,f[i]-1]串就是一个能匹配i-1位置的最长的前缀串。且我们根据f[i]的值可以定位其他所有可匹配的前缀。KMP的思想就是找出每个位置i的可匹配最大前缀j。

 令dp[i]表示S[0,i-1]串的后缀能匹配的前缀个数,那么dp[i]=dp[next[i]]+1, dp[1]=1正好表示串s[0]的后缀只能匹配串s[0].
 

AC代码:

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<vector>
#include<stdlib.h>
#include<queue>
#include<map>
#include<set>
#include<iomanip>
#include<math.h>
using namespace std;
typedef long long ll;
typedef double ld;
int dp[200005],n,nxt[200005];
char p[200005];

void getNext()
{
	int pLen=strlen(p);
	nxt[0]=-1;
	int k=-1;
	int j=0;
	while(j<pLen)
	{
		//p[k]表示前缀,p[j]表示后缀
		if(k==-1||p[j]==p[k])
		{
			++k;
			++j;
			nxt[j]=k;
		}
		else
		{
			k=nxt[k];
		}
	}
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        scanf("%s",p);
        getNext();
        int len=strlen(p);
        for(int i=1; i<=n; i++)
            dp[i]=1;
        dp[0]=0;
        int ans=0;
        for(int i=1; i<=n; i++)
        {
            dp[i]=dp[nxt[i]]+1;
            ans+=dp[i]%10007;
        }
        printf("%d\n",ans%10007);
    }
}

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值