HDU3336——Count the string【扩展KMP】

Count the string

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 14735    Accepted Submission(s): 6734


 

Problem Description

It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:
s: "abab"
The prefixes are: "a", "ab", "aba", "abab"
For each prefix, we can count the times it matches in s. So we can see that prefix "a" matches twice, "ab" matches twice too, "aba" matches once, and "abab" matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For "abab", it is 2 + 2 + 1 + 1 = 6.
The answer may be very large, so output the answer mod 10007.

 

 

Input

The first line is a single integer T, indicating the number of test cases.
For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.

 

 

Output

For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.

 

 

Sample Input

 

1 4 abab

 

 

Sample Output

 

6

 

 

Author

foreverlin@HNU

 

Source和就是

HDOJ Monthly Contest – 2010.03.06

 

题目大意:给你一个字符串,问这个字符串的每一个前缀在这个字符串中出现的次数之和。

大致思路:看到处理字符串的前缀的问题我们可以是这去联想扩展KMP算法,在扩展KMP算法中next[i]表示在字符串T中从T[i]~T[len - 1]与字符串T的最长公共前缀长度。然后next[I]的  和就是我们要求解的答案。

#include <bits/stdc++.h>
#define mod 10007
using namespace std;

typedef long long ll;
const int MAXN = 2000100;
char s[MAXN];
ll NextVal[MAXN];

void GetNextVal(char *str){
	int i = 0, j, pos, len = strlen(str);
	NextVal[0] = len;
	while(str[i] == str[i + 1] && i + 1 < len) i++;
	NextVal[1] = i;
	pos = 1;
	for(i = 2; i < len; i++){
		if(NextVal[i - pos] + i < NextVal[pos] + pos) NextVal[i] = NextVal[i - pos];
		else{
			j = NextVal[pos] + pos - i;
			if(j < 0) j = 0;
			while(i + j < len && str[j] == str[j + i]) j++;
			NextVal[i] = j;
			pos = i; 
		}
	}
}

int main(int argc, char const *argv[])
{
	int t;
	scanf("%d",&t);
	while(t--){
		int n;
		scanf("%d",&n);
		scanf("%s",s);
		GetNextVal(s);
		ll sum = 0;
		for(ll i = 0; i < n; i++){
			sum = (sum + NextVal[i]) % mod;
		}
		printf("%lld\n",sum);
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值