HDU2717 Catch That Cow (BFS)

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

 

题意:

给出一个起始位置,给出一个末位置,有三种走法,向左向右,走当前位置的二倍。每走一步用时一分钟,求最短用时。

ac代码:

 

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<string>
#include<map>
#include<stack>
#include<vector>
#include<set>
#include<queue>
using namespace std;

struct node
{
	int x,step;
}no;
queue <node> q;
int vis[200000];
int n,k;
int bfs()
{
	while (!q.empty())
        q.pop();//多组数据,每次都要清空队列
	memset(vis,0,sizeof vis);//将访问数组初始化
	vis[no.x]=1;//将起始位置标记为访问过
	q.push(no);//将初始位置加入队列
	while(!q.empty())
       {
		node now=q.front();
		if(now.x==k)
		return now.step;//找到了就直接返回值
		for(int j=0;j<3;j++)//3种走法全部枚举
		{
			node next=now;
			if(j==0)
			next.x=next.x+1;
			else if(j==1)
			next.x=next.x-1;
			else if(j==2)
			next.x=next.x*2;
			next.step++;//步数加1
			if(next.x==k)
			return next.step;
			if(next.x>=0&&next.x<=200000&&!vis[next.x])//判断是否越界
			{
				vis[next.x]=1;
				q.push(next);
			}
		}
		q.pop();
	}
	return 0;
}

int main()
{
	while(~scanf("%d %d",&n, &k))
        {
		no.x=n;
		no.step=0;
		printf("%d\n",bfs());
	}
	return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值