ZOJ4118 Stones in the Bucket

Description:

intput:

output:

Sample Input

4
3
1 1 0
4
2 2 2 2
3
0 1 4
1
1000000000

Sample Output

2
0
3
0

Hint

For the first sample test case, one can remove all the stones in the first two buckets.

For the second sample test case, as all the buckets have already contained the same number of stones, no operation is needed.

For the third sample test case, one can move 1 stone from the 3rd bucket to the 1st bucket and then remove 2 stones from the 3rd bucket.

题意:

给出n个桶和每个桶里的石子数,一次移动一个石头,求最少多少次移动使桶里的石子输相等。

只要求出平均数,每个桶里的石子输只要大于平均数的取差加和最后输出就行。

AC代码:

#include<iostream>
#include<math.h>
#include<string.h>
#include<stdio.h>
#include<algorithm>
using namespace std;
typedef long long ll;
ll a[100010];
int main()
{
    int i,j,l;
    int t;
    ll n,k;
    ll ans,sum;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%lld",&n);
        sum=0;
        ans=0;
       for(i=0;i<n;i++)
       {
           scanf("%lld",&a[i]);
           sum+=a[i];
       }
        sum/=n;
        for(i=0;i<n;i++)
        {
            if(a[i]>sum)
               {
                  ans+=a[i]-sum;
               }
        }
        printf("%lld\n",ans);
    }
    return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值