HDU6438 Buy and Resell(贪心+ STL)

Description:

The Power Cube is used as a stash of Exotic Power. There are nn cities numbered 1,2,…,n1,2,…,n where allowed to trade it. The trading price of the Power Cube in the ii-th city is aiai dollars per cube. Noswal is a foxy businessman and wants to quietly make a fortune by buying and reselling Power Cubes. To avoid being discovered by the police, Noswal will go to the ii-th city and choose exactly one of the following three options on the ii-th day: 

1. spend aiai dollars to buy a Power Cube 
2. resell a Power Cube and get aiai dollars if he has at least one Power Cube 
3. do nothing 

Obviously, Noswal can own more than one Power Cubes at the same time. After going to the nn cities, he will go back home and stay away from the cops. He wants to know the maximum profit he can earn. In the meanwhile, to lower the risks, he wants to minimize the times of trading (include buy and sell) to get the maximum profit. Noswal is a foxy and successful businessman so you can assume that he has infinity money at the beginning. 

Input

There are multiple test cases. The first line of input contains a positive integer TT (T≤250T≤250), indicating the number of test cases. For each test case: 
The first line has an integer nn. (1≤n≤1051≤n≤105) 
The second line has nn integers a1,a2,…,ana1,a2,…,an where aiai means the trading price (buy or sell) of the Power Cube in the ii-th city. (1≤ai≤1091≤ai≤109) 
It is guaranteed that the sum of all nn is no more than 5×1055×105. 

Output

For each case, print one line with two integers —— the maximum profit and the minimum times of trading to get the maximum profit.

Sample Input

3
4
1 2 10 9
5
9 5 9 10 5
2
2 1

Sample Output

16 4
5 2
0 0

商人能在N个地方以aiai的价格买入或卖出商品,在每个地方只能做一次交易。要求最大的收益,同时最小化交易次数。

从左到右枚举,并把每个数插入set当中,每次询问到i位置时,查看set中最小的值a是否小于第i个数b,如果小于,加上它们的差值,并且插入两个b进去,第二个b是为了反悔用到,假设我后面有值c>b,那么显然c-a要优于b-a,此时的c-b+b-a刚好变成c-a,另外的一个b就是正常的插入了,当然反悔的b不用再增加次数。如果b<=a,则只插入一个b就可以了。

AC代码:

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<vector>
#include<stdlib.h>
#include<queue>
#include<map>
#include<set>
#include<iomanip>
#include<math.h>
using namespace std;
typedef long long ll;
typedef double ld;
const int INF = 0x3f3f3f3f;
const int N=1000010;
int i,j,k;
int m,n,t;
int p,q;
int l,r;
int a,b,c;
ll res,cnt,ans,temp,x;
multiset< pair<ll,int> >s;


int main()
{
    scanf("%d",&t);
    while(t--)
    {
        ans=0;
        cnt=0;
        scanf("%d",&n);
        s.clear();
        for(i=0 ; i<n; i++)
        {
            scanf("%lld",&x);
            if(s.empty())
                s.insert({x, 1});
            else
            {
                if((s.begin()->first) < x)
                {
                    ans+=x-(s.begin()->first);
                    cnt+=(s.begin()->second);
                    pair<ll,int>tmp=*s.begin();
                    s.erase(s.begin());
                    if(tmp.second==0)
                        s.insert({tmp.first, 1});
                    s.insert({x, 0});
                }
                else
                    s.insert({x,1});
            }
        }
        printf("%lld %lld\n",ans,cnt*2);
    }
    return 0;
}

 

  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值