HDU - 6489 The puzzle

Description:

Kayaking is playing a puzzle game containing n different blocks. He marks the blocks with integers from 1 to n, which show the blocks’ original positions. Each time he can exchange two blocks and he wants to know how many times he needs at least to restore the puzzle.

Input

The input starts with one line contains exactly one positive integer which is the number of test cases. 
Each test case contains two lines. 
The first line contains an integer, which indicates the number of puzzle pieces. 
The second line contains n different integers, the i-th number means the mark of the block in the i-th position.

Output

For each test case, output one line with one number represents the minimum operations.

Sample Input

2
4
2 3 4 1
4
2 1 4 3

Sample Output

3
2

 

Hint

1<=T<=20,1<=n<=100000

 题意:

       给出1-n这些数,不按照顺序排列,求交换几次可以使得从小到大排列。

一开始以为是模拟冒泡排序结果会超时。

然后优化到一重循环。

AC代码:

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
typedef long long ll;
#define inf 0x3f3f3f3f
#define maxn 100005
using namespace std;
char str[maxn];
typedef long long ll;
int a[maxn],id[maxn];
int main()
{
    int t;
    while (~scanf("%d",&t))
    {
        while (t--)
        {
            int n;
            scanf("%d",&n);
            for (int i=1; i<=n; i++)
            {
                scanf("%d",&a[i]);
                id[a[i]]=i;
            }
            int ans=0;
            for (int i=1; i<=n; i++)
            {
                if (a[i]!=i)
                {
                    ans++;
                    int tmp=a[i],idd=id[i];
                    swap(a[i],a[id[i]]);
                    swap(id[tmp],id[i]);
                }
            }
            printf("%d\n",ans);
        }
    }
    return 0;
}


 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值