poj1017——Packets

http://poj.org/problem?id=1017

Description

A factory produces products packed in square packets of the same height h and of the sizes 1*1, 2*2, 3*3, 4*4, 5*5, 6*6. These products are always delivered to customers in the square parcels of the same height h as the products have and of the size 6*6. Because of the expenses it is the interest of the factory as well as of the customer to minimize the number of parcels necessary to deliver the ordered products from the factory to the customer. A good program solving the problem of finding the minimal number of parcels necessary to deliver the given products according to an order would save a lot of money. You are asked to make such a program.

Input

The input file consists of several lines specifying orders. Each line specifies one order. Orders are described by six integers separated by one space representing successively the number of packets of individual size from the smallest size 1*1 to the biggest size 6*6. The end of the input file is indicated by the line containing six zeros.

Output

The output file contains one line for each line in the input file. This line contains the minimal number of parcels into which the order from the corresponding line of the input file can be packed. There is no line in the output file corresponding to the last ``null'' line of the input file.

Sample Input

0 0 4 0 0 1 
7 5 1 0 0 0 
0 0 0 0 0 0 

Sample Output

2 
1 

题意:就是一个6*6的背包,装入物品分别为1*1,2*2,3*3,4*4,5*5,6*6

可知6*6和5*5是一个物品,一个背包,把多余格子用来装1*1,3*3和4*4可以用来装2*2和1*1;

此题注意一下像上取整

a/b
        // 向下取整
(a+(b-1))/b 
        // 向上取整
int(float(a)/b + .5) 
        // 四舍五入

接下来就上代码吧

#include<iostream>
#include<math.h>
using namespace std;


int a[9];
int a3[]={0,5,3,1}; 
int sum=0;

int main() 
{
	
	while(1){
		sum=0;
		for(int i=1;i<=6;i++){
			cin >> a[i];
			sum+=a[i];
		}
		if(sum==0){
			break;
		}
		sum=a[6]+a[5]+a[4]+(a[3]+3)/4;//a[3]向上取整 
		
		int a2=a[4]*5+a3[a[3]%4];//判断2有多少剩余2*2的格子 
		
		if(a2<a[2]){
			sum+=(a[2]-a2+8)/9;//向上取整 
		}
		
		int a1=sum*36-a[2]*4-a[3]*9-a[4]*16-a[5]*25-a[6]*36;//判断剩余1*1 
		
		if(a1<a[1]){
			sum+=(a[1]-a1+35)/36;
		}
		
		cout << sum << endl;
	}
	return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值