HDU Problem - 6124 Euler theorem

HazelFan is given two positive integers a,ba,b, and he wants to calculate amodbamodb. But now he forgets the value of bb and only remember the value of aa, please tell him the number of different possible results.

Input

The first line contains a positive integer T(1≤T≤5)T(1≤T≤5), denoting the number of test cases.
For each test case:
A single line contains a positive integer a(1≤a≤109)a(1≤a≤109).

Output

For each test case:
A single line contains a nonnegative integer, denoting the answer.

Sample Input

2
1
3

Sample Output

2
3

打表显而易见

代表代码:

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#include<cmath>
using namespace std;
typedef long long ll;
int m[100010];
int main()
{
    int t,n;
    //scanf("%d",&t);
    for(int j=1; j<=100; j++)
    {
        n=j;
        int ans=0;
        memset(m,0,sizeof(m));
        // scanf("%d",&n);
        for(int i=1; i<=n; i++)
        {
            if(m[n%i]==0)
                ans++,m[n%i]=1;
        }
        printf("%d ",ans+1);
    }
    return 0;
}

打表结果:

代码:

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#include<cmath>
using namespace std;
typedef long long ll;
int main()
{
    int t,n;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        if(n%2==1)
            printf("%d\n",n/2+2);
        else
            printf("%d\n",n/2+1);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值