hdu 1452 Happy 2004(费马小定理+因数和公式+积性函数)

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 2493 Accepted Submission(s): 1802
Problem Description

Consider a positive integer X,and let S be the sum of all positive integer divisors of 2004^X. Your job is to determine S modulo 29 (the rest of the division of S by 29).

Take X = 1 for an example. The positive integer divisors of 2004^1 are 1, 2, 3, 4, 6, 12, 167, 334, 501, 668, 1002 and 2004. Therefore S = 4704 and S modulo 29 is equal to 6.

Input

The input consists of several test cases. Each test case contains a line with the integer X (1 <= X <= 10000000).

A test case of X = 0 indicates the end of input, and should not be processed.

Output

For each test case, in a separate line, please output the result of S modulo 29.

Sample Input

1
10000
0

Sample Output

6
10

分析:

整数分解

#include<iostream>
#include<cstdio>
using namespace std;

int pp(int a,int b) {
    int ret=1;
    while(b) {
        if(b&1) {
            ret*=a;
            ret%=29;
        }
        a*=a;
        a%=29;
        b>>=1;
    }
    return ret;
}

int main() {
    int n;

    while(~scanf("%d",&n)&&n) {
        int ans1=(pp(2,2*n+1)-1)%29;
        int ans2=(pp(3,n+1)-1)%29*pp(2,27)%29;
        int ans3=(pp(22,n+1)-1)%29*pp(21,27)%29;
        printf("%d\n",ans1*ans2*ans3%29);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值