PTA甲级 1032 Sharing (C++)

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, loading and being are stored as showed in Figure 1.
Figure 1
You are supposed to find the starting position of the common suffix (e.g. the position of i in Figure 1).

Input Specification:

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N ( ≤ 1 0 5 ) N (≤10^5) N(105), where the two addresses are the addresses of the first nodes of the two words, and N N N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by − 1 −1 1.

Then N N N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is the letter contained by this node which is an English letter chosen from { a-z, A-Z }, and Next is the position of the next node.

Output Specification:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output -1 instead.

Sample Input 1:

11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010

Sample Output 1:

67890

Sample Input 2:

00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1

Sample Output 2:

-1

Caution:

自己本来的思路是在读数据的时候同时更新每个点的入度,如果碰到哪个点的入度是2的话就说明从这里开始共享内存了,但是自己的代码一直有两个测试点过不了,看了看柳神的代码后换了个方法过了。

但是还是很郁闷🤨,如果有大佬看出来是哪里错的话麻烦留言一下,感谢!!

先贴出有错的代码:

// Talk is cheap, show me the code
// Created by Misdirection 2021-08-15 17:13:40
// All rights reserved.

#include <iostream>
#include <vector>
#include <unordered_map>

using namespace std;

int main(){
    unordered_map<string, int> inDu; // 入度
    string s1, s2;
    int n;

    cin >> s1 >> s2 >> n;
    if(s1 == s2){
        printf("%s\n", s1.c_str());
        return 0;
    }

    inDu[s1] = 1;
    inDu[s2] = 1;

    for(int i = 0; i < n; ++i){
        char c;

        cin >> s1 >> c >> s2;
        
        if(inDu[s2] >= 1){
            printf("%s\n", s2.c_str());
            return 0;
        }
        else inDu[s2] = 1;
    }
        
    return 0;
}

在这里插入图片描述

Solution

// Talk is cheap, show me the code
// Created by Misdirection 2021-08-15 17:13:40
// All rights reserved.

#include <iostream>
#include <vector>
#include <unordered_map>

using namespace std;

int main(){
    unordered_map<string, pair<string, bool>> map;
    string s1, s2;
    int n;

    cin >> s1 >> s2 >> n;

    for(int i = 0; i < n; ++i){
        string a, b;
        char c;

        cin >> a >> c >> b;

        map[a] = {b, false};
    }

    string s = s1; 
    while(s != "-1"){
        map[s].second = true;
        s = map[s].first;
    }

    s = s2;

    while(s != "-1"){
        if(map[s].second == true){
            printf("%s\n", s.c_str());
            return 0;
        }
        s = map[s].first;
    }

    printf("-1\n");
        
    return 0;
}

在这里插入图片描述

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

负反馈循环

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值