PTA甲级 1047 Student List for Course (C++)

Zhejiang University has 40,000 students and provides 2,500 courses. Now given the registered course list of each student, you are supposed to output the student name lists of all the courses.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N ( ≤ 40 , 000 ) N (≤40,000) N(40,000), the total number of students, and K ( ≤ 2 , 500 ) K (≤2,500) K(2,500), the total number of courses. Then N N N lines follow, each contains a student’s name (3 capital English letters plus a one-digit number), a positive number C ( ≤ 20 ) C (≤20) C(20) which is the number of courses that this student has registered, and then followed by C C C course numbers. For the sake of simplicity, the courses are numbered from 1 to K K K.

Output Specification:

For each test case, print the student name lists of all the courses in increasing order of the course numbers. For each course, first print in one line the course number and the number of registered students, separated by a space. Then output the students’ names in alphabetical order. Each name occupies a line.

Sample Input:

10 5
ZOE1 2 4 5
ANN0 3 5 2 1
BOB5 5 3 4 2 1 5
JOE4 1 2
JAY9 4 1 2 5 4
FRA8 3 4 2 5
DON2 2 4 5
AMY7 1 5
KAT3 3 5 4 2
LOR6 4 2 4 1 5

Sample Output:

1 4
ANN0
BOB5
JAY9
LOR6
2 7
ANN0
BOB5
FRA8
JAY9
JOE4
KAT3
LOR6
3 1
BOB5
4 7
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1
5 9
AMY7
ANN0
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1

Solution:

// Talk is cheap, show me the code
// Created by Misdirection 2021-08-17 17:52:24
// All rights reserved.

#include <iostream>
#include <vector>
#include <string>
#include <algorithm>

using namespace std;

int main(){
    int n, k;
    // n - the total number of students
    // k - the total number of courses

    scanf("%d %d", &n, &k);
    vector<vector<string>> courses(k + 1);

    for(int i = 0; i < n; ++i){
        string name;
        int numOfCourses;

        cin >> name >> numOfCourses;

        for(int j = 0; j < numOfCourses; ++j){
            int course;
            scanf("%d", &course);

            courses[course].push_back(name);
        }
    }

    for(int i = 0; i < k; ++i){
        sort(courses[i + 1].begin(), courses[i + 1].end());

        printf("%d %d\n", i + 1, (int)courses[i + 1].size());
        for(int j = 0; j < courses[i + 1].size(); ++j) printf("%s\n", courses[i + 1][j].c_str());
    }


    return 0;
}

在这里插入图片描述

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

负反馈循环

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值