PTA甲级 1062 Talent and Virtue (C++)

About 900 years ago, a Chinese philosopher Sima Guang wrote a history book in which he talked about people’s talent and virtue. According to his theory, a man being outstanding in both talent and virtue must be a “sage(圣人)”; being less excellent but with one’s virtue outweighs talent can be called a “nobleman(君子)”; being good in neither is a “fool man(愚人)”; yet a fool man is better than a “small man(小人)” who prefers talent than virtue.

Now given the grades of talent and virtue of a group of people, you are supposed to rank them according to Sima Guang’s theory.

Input Specification:

Each input file contains one test case. Each case first gives 3 positive integers in a line: N ( ≤ 1 0 5 ) N (≤10^5) N(105), the total number of people to be ranked; L ( ≥ 60 ) L (≥60) L(60), the lower bound of the qualified grades – that is, only the ones whose grades of talent and virtue are both not below this line will be ranked; and H ( < 100 ) H (<100) H(<100), the higher line of qualification – that is, those with both grades not below this line are considered as the “sages”, and will be ranked in non-increasing order according to their total grades. Those with talent grades below H H H but virtue grades not are cosidered as the “noblemen”, and are also ranked in non-increasing order according to their total grades, but they are listed after the “sages”. Those with both grades below H H H, but with virtue not lower than talent are considered as the “fool men”. They are ranked in the same way but after the “noblemen”. The rest of people whose grades both pass the L L L line are ranked after the “fool men”.

Then N N N lines follow, each gives the information of a person in the format:

ID_Number Virtue_Grade Talent_Grade

where ID_Number is an 8-digit number, and both grades are integers in [0, 100]. All the numbers are separated by a space.

Output Specification:

The first line of output must give M ( ≤ N ) M (≤N) M(N), the total number of people that are actually ranked. Then M M M lines follow, each gives the information of a person in the same format as the input, according to the ranking rules. If there is a tie of the total grade, they must be ranked with respect to their virtue grades in non-increasing order. If there is still a tie, then output in increasing order of their ID’s.

Sample Input:

14 60 80
10000001 64 90
10000002 90 60
10000011 85 80
10000003 85 80
10000004 80 85
10000005 82 77
10000006 83 76
10000007 90 78
10000008 75 79
10000009 59 90
10000010 88 45
10000012 80 100
10000013 90 99
10000014 66 60

Sample Output:

12
10000013 90 99
10000012 80 100
10000003 85 80
10000011 85 80
10000004 80 85
10000007 90 78
10000006 83 76
10000005 82 77
10000002 90 60
10000014 66 60
10000008 75 79
10000001 64 90

Solution:

// Talk is cheap, show me the code
// Created by Misdirection 2021-08-19 21:53:05
// All rights reserved.

#include <iostream>
#include <vector>
#include <algorithm>

using namespace std;

int l, h;

struct People{
    string name;
    int virtueGrade;
    int talentGrade;
    int tag;
    int total;
    // tag == 0 : 圣人;
    // tag == 1 : 君子;
    // tag == 2 : 愚人
    // tag == 3 : 小人

    People(string n, int v, int t){
        name = n;
        virtueGrade = v;
        talentGrade = t;
        total = v + t;

        if(virtueGrade >= h && talentGrade >= h) tag = 0;
        // those with both grades not below this line are considered as the "sages"

        else if(virtueGrade >= h && talentGrade < h) tag = 1;
        // Those with talent grades below H but virtue grades not are cosidered as the "noblemen"

        else if(virtueGrade < h && talentGrade < h && virtueGrade >= talentGrade) tag = 2;
        // Those with both grades below H, but with virtue not lower than talent are considered as the "fool men"

        else tag = 3;
    }

    ~People(){}
};


bool cmp(People& a, People& b){
    if(a.tag != b.tag) return a.tag < b.tag;
    else if(a.total != b.total) return a.total > b.total;
    else if(a.virtueGrade != b.virtueGrade) return a.virtueGrade > b.virtueGrade;
    else return a.name < b.name;
}


int main(){
    int n;
    // n - the total number of people to be ranked
    // l - the lower bound of the qualified grades(两个分数都大于等于 l 才会进行排名)
    // h - the higher line of qualification(两个分数都大于等于 h 则被视为圣人)

    scanf("%d %d %d", &n, &l, &h);

    // 排序规则:圣人(两个分数都大于等于h)比君子(才能分数低于 h,品德分数高于 h)在前
    // 君子在愚人(两个分数都低于 h,但是品德分数大于等于才能)前
    // 愚人在小人前
    // 其他的是小人

    vector<People> people;

    string name;
    int v, t;

    for(int i = 0; i < n; ++i){
        cin >> name >> v >> t;

        if(v >= l && t >= l) people.emplace_back(name, v, t);
    }

    sort(people.begin(), people.end(), cmp);

    printf("%d\n", (int)people.size());

    for(int i = 0; i < people.size(); ++i) 
        printf("%s %d %d\n", people[i].name.c_str(), people[i].virtueGrade, people[i].talentGrade);

    return 0;
}

在这里插入图片描述

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

负反馈循环

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值